activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From cmose <cjm...@gmail.com>
Subject MasterSlave failover question
Date Wed, 09 Aug 2006 21:26:50 GMT

I'm trying to fiddle around with the master slave configuration in 4.01 using
a few simplistic test jms sender and receiver files. Basically I'm running 2
instances of activemq on my pc and have one configured as a master and one
configured as a slave. Both instances load up, and I see the correct logging
information in the command window regarding attachment of a slave and if the
master is shutdown, the slave shows that it apes the state of the master
prior to the shutdown and etc.,

The trouble is that my test receiver program that just sits there consuming
messages dies if the master broker is shutdown (even if the slave broker is
still up and running). If i restart the test receiver program it will
connect to the slave and run just fine however, I was under the impression
that it was meant to just keep plugging along if the master broker went down
(no exception is thrown or anything of that nature that I could trap and
attempt to initiate a reconnect).

Any advice (or requests for additional information to be able to provide
advice)?

- I'm using the following connection string (using a jndi.properties file):
failover://(tcp://localhost:61616,tcp://localhost:61617)?randomize=false
-- 
View this message in context: http://www.nabble.com/MasterSlave-failover-question-tf2081356.html#a5734206
Sent from the ActiveMQ - User forum at Nabble.com.


Mime
View raw message