activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matthew Xie <ant_mira...@163.com>
Subject Problem from open wire dotnet send float properties message to java
Date Mon, 07 Aug 2006 06:07:48 GMT

I found a problem while i using open wire dotnet api to send float property
message to java platform, the value i recieved that is deffrent with the
value setting in dotnet platform.

here is send value(dotnet) is:  float floatvalue = 2.1F
recieved value(java) is value is: 1.757237E-26

is this a bug or i make some mistake in my test?

follow is my test code:
dotnet:

            float value= 2.12F;
            Uri uri = new Uri("tcp://" + ip +
":61616?jms.useAsyncSend=true");
            factory = new ConnectionFactory(uri);
            using (IConnection connection = factory.CreateConnection())
            {
                ISession session =
connection.CreateSession(acknowledgementMode);

                IDestination destination = session.GetQueue(queueName);

                IMessageProducer producer =
session.CreateProducer(destination);
                producer.Persistent = true;

                // lets send a message
                String text = "text";
                ITextMessage request = session.CreateTextMessage(text);
                request.NMSPersistent = true;
                request.NMSCorrelationID = "abc";
   
                request.Properties["custom8"] = custom8;

                producer.Send(request);

            }

java:
public void onMessage(Message message) {
           System.out.println(message.getFloatProperty("custom8"));
}

could someone do me a favor?
Thx!

Matt
-- 
View this message in context: http://www.nabble.com/Problem-from-open-wire-dotnet-send-float-properties-message-to-java-tf2061832.html#a5679943
Sent from the ActiveMQ - User forum at Nabble.com.


Mime
View raw message