activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pep <pep_cod...@yahoo.es>
Subject ActiveMQ Hangs on OC4J
Date Tue, 01 Aug 2006 08:54:53 GMT

Hi,

we deployed ActiveMQ as an embedded broker in OC4J 10.1.3. Everything seemed
to work fine but we are experiencing some hangs in ActiveMQ after delivering
some messages (sometimes a lot of messages, sometimes just a few ones). When
ActiveMQ is hang, we try to connect with Hermes, but we are unable to browse
the Queue's contents, Hermes just stays trying to connect. 

Furthermore, we are still able to navigate to other parts of the application
which do not interact with ActiveMQ. This indicates that OC4J is still
alive. But as soon we call a feature that interacts with ActiveMQ by
producing messages, then we get the whole system hanged or not working
properly. 

Unfortuatelly, we do not receive any exception or message that may help
identify where the hang is produced (we set log4j traces to DEBUG level). We
are using VM transport protocol inside our application and tcp protocol from
Hermes.

Did anyone experience a similar problem? I looked in the Jira repository of
ActiveMQ but I could not find any issue similar to this one.  Is there any
way to get detailed info of what is being hang? 

Thanks in advance,

Pep.
-- 
View this message in context: http://www.nabble.com/ActiveMQ-Hangs-on-OC4J-tf2032286.html#a5590730
Sent from the ActiveMQ - User forum at Nabble.com.


Mime
View raw message