activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sandeep Chayapathi <sand...@wssource.com>
Subject Re: AMQ 4.0.1 - master/slave woes
Date Mon, 21 Aug 2006 14:43:58 GMT
Thanks. However even after setting "persistent:true" header for the 
stomp message, the slave did not replicate the message. As mentioned 
earlier, I have 2 instances of AMQ:
  . one on port 61616 & stomp on 61613
  . other on port 61615 and stomp on 61612

if the slave's activemq.xml has this entry for the broker:

----
<broker useJmx="true" name="TEST" 
masterConnectorURI="tcp://localhost:61616" shutdownOnMasterFailure="false" >
...
----

the test client never connects to the master server, that is Im able to 
send stomp connect message, but the server never responds with the 
CONNECTED header.

 However, on the slave borker if I set the masterConnectorURI to 61613 as:
----
<broker useJmx="true" name="TEST" 
masterConnectorURI="tcp://localhost:61613" shutdownOnMasterFailure="false" >
...
----

the test  is able to connect and send message to the master server, 
however the slave server never replicates the message ( there is no 
other client subscribed to the queue)/

- Sandeep

James Strachan wrote:
> I thought queues were persistent by default but you can specify the
> explicit persistence mode via a header...
>
> http://incubator.apache.org/activemq/stomp.html
>
> i.e. adding persistent: true
>
>
>
> On 8/18/06, Sandeep Chayapathi <sandeep@wssource.com> wrote:
>> Hi all,
>>   Im trying to setup AMQ 4.0.1 in master/slave mode. Im running both
>> master & slave from the same box, but on different ports. Both have
>> different data store (different data folders).
>> Im able to see in the log file, that the slave attaches itself to the
>> master service.
>>
>>   I have a test stomp client, which sends messages to: /queue/FOO.test
>> queue. After storing some 20 messages, I stop the master server (ctrl+C
>> the app).  Then start another stomp client, which tries to read
>> /queue/FOO.test, from the slave server. I'm able to connect to the
>> slave, but the slave does not have any message. I have followed the
>> instructions given in: http://activemq.org/site/masterslave.html. Im not
>> sure if the replication is only for durable queues. If so, how do I
>> create durable queues via stomp ? Thanks.
>>
>> - Sandeep
>>
>
>


Mime
View raw message