activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Strachan" <james.strac...@gmail.com>
Subject Re: sending stomp messages to activemq client
Date Mon, 17 Jul 2006 14:26:08 GMT
On 7/17/06, ldangelo <ldangelo@mac.com> wrote:
>
> James,
>
> Thank you for the reply.
>
> I can see the messages using jconsole, however the servicemix destination
> does not receive the message.

Maybe its a destination issue - you are sending to the wrong
destination for the servicemix destination to receive? e.g. try using
a JMS consumer first - such as the hello world producer/consumer
examples that ship with ActiveMQ. Once you've verified that your
messages work and you can consume them, then look at what your
servicemix configuration is consuming from etc.


> My activemq.xml config file has two transports:
>
> <transportConnectors>
>      15        <transportConnector uri="tcp://localhost:61616"
> discoveryUri="multicast://default"
>      15 />
>      16        <transportConnector name="stomp"
> uri="stomp://localhost:61613"/>
>      17
>      18     </transportConnectors>
>
> my stomp client is connecting to localhost:61613...  Is that right? My java
> client connects to 61616?  How does activemq "know" how to route messages
> back and forth from 61613 to 61616?

Yes. All <transportConnector> connect to the same broker and messages
can flow bidirectionally over any of them

-- 

James
-------
http://radio.weblogs.com/0112098/

Mime
View raw message