activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Strachan" <james.strac...@gmail.com>
Subject Re: JMS to JMS Bridge
Date Wed, 12 Jul 2006 07:32:38 GMT
I cant remember which version supported the <jmsQueueConnector> XMl
syntax I'm afraid; it might have not been in 4.0; I wonder does trying
4.0.1 or 4.1-SNAPSHOT help at all?

On 7/11/06, Tom Purcell <tpurcell@chariotsolutions.com> wrote:
>
> Hello
>
> Hope you don't mind me barging in but I'm trying to do almost the same
> thing. I am trying to bridge from Weblogic 8.1 (WLS) to ActiveMQ 4.0. When I
> start ActiveMQ I get all the typical Spring type initialization messages and
> then the following message:
>
> INFO  JmsConnector                   - JMS Connector
> JreportRequestBridge-Inbound Started
>
> So it appears all is cool but when I send a message nothing seems to happen.
> On the WLS side I can see the the message has been produced but I get no
> reaction on the ActiveMQ side. My activemq.xml configuration file is below.
> Any thoughts would be appreciated.
>
> Thanks
> Tom
>
> <beans xmlns="http://activemq.org/config/1.0">
>
>   <broker useJmx="true">
>
>     <persistenceAdapter>
>       <journaledJDBC journalLogFiles="5" dataDirectory="../activemq-data"/>
>     </persistenceAdapter>
>
>     <transportConnectors>
>        <transportConnector name="default" uri="tcp://localhost:61616"
> discoveryUri="multicast://default"/>
>        <transportConnector name="stomp"   uri="stomp://localhost:61613"/>
>     </transportConnectors>
>
>     <networkConnectors>
>       <networkConnector name="default" uri="multicast://default"/>
>     </networkConnectors>
>
>     <jmsBridgeConnectors>
>      <jmsQueueConnector name="JreportRequestBridge-Inbound"
>         outboundQueueConnectionFactory="#remoteFactory"
>         outboundUsername="user"
>         outboundPassword="password"
>         localQueueConnectionFactory="#localFactory">
>         <inboundQueueBridges>
>           <inboundQueueBridge inboundQueueName="jms/queue/jreport/request"
>              consumerQueue="#localQueue"/>
>         </inboundQueueBridges>
>       </jmsQueueConnector>
>     </jmsBridgeConnectors>
>
>   </broker>
>
>   <bean id="remoteFactory"
>     class="org.apache.activemq.ActiveMQConnectionFactory">
>     <properties>
>        <property name="java.naming.factory.initial"
> value="weblogic.jndi.WLInitialContextFactory"/>
>        <property name="java.naming.provider.url"
> value="t3://nnn.nnn.nnn.nnn:7001"/>
>     </properties>
>   </bean>
>
>   <bean id="localFactory"
>     class="org.apache.activemq.ActiveMQConnectionFactory">
>     <property name="brokerURL" value="tcp://localhost:61616" />
>   </bean>
>
>   <bean id="localQueue" class="org.apache.activemq.command.ActiveMQQueue">
>     <constructor-arg value="dynamic/jms.queue.jreport.request"/>
>   </bean>
>
> </beans>
>
>
> --
> View this message in context: http://www.nabble.com/JMS-to-JMS-Bridge-tf1901141.html#a5276953
> Sent from the ActiveMQ - User forum at Nabble.com.
>
>


-- 

James
-------
http://radio.weblogs.com/0112098/

Mime
View raw message