activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Strachan" <james.strac...@gmail.com>
Subject Re: Mixing Spring and XBean XML configuration
Date Tue, 04 Jul 2006 13:18:19 GMT
Does this work any better...

<?xml version="1.0" encoding="UTF-8"?>
<beans>
       <broker xmlns="http://activemq.org/config/1.0">
               <transportConnectors>
                       <transportConnector name="default"
uri="tcp://localhost:61616"/>
               </transportConnectors>

               <jmsBridgeConnectors>

       <bean xmlns=""
class="org.apache.activemq.network.jms.JmsQueueConnector"/>

               </jmsBridgeConnectors>
       </broker>
</beans>

On 7/4/06, ENP <prokopiev@stc.donpac.ru> wrote:
>
> This is not work:
>
> [john@prokopiev bin]$ cat ../conf/activemq.xml
> <?xml version="1.0" encoding="UTF-8"?>
> <beans>
>         <broker xmlns="http://activemq.org/config/1.0">
>                 <transportConnectors>
>                         <transportConnector name="default"
> uri="tcp://localhost:61616"/>
>                 </transportConnectors>
>                 <jmsBridgeConnectors>
>                         <ref bean="jmsConnector"/>
>                 </jmsBridgeConnectors>
>         </broker>
>         <bean id="jmsConnector"
> class="org.apache.activemq.network.jms.JmsQueueConnector"/>
> </beans>
> [john@prokopiev bin]$ sh activemq
> ACTIVEMQ_HOME: /home/john/devel/java/jms/incubator-activemq-4.0-bridged
> Loading message broker from: xbean:activemq.xml
> INFO  XBeanXmlBeanDefinitionReader   - Loading XML bean definitions from
> class path resource [activemq.xml]
> DEBUG XBeanXmlBeanDefinitionReader   - Using JAXP implementation
> [com.sun.org.apache.xerces.internal.jaxp.DocumentBuilderFactoryImpl@587c94]
> DEBUG XBeanXmlBeanDefinitionParser   - Loading bean definitions
> DEBUG XBeanXmlBeanDefinitionParser   - Default lazy init ''
> DEBUG XBeanXmlBeanDefinitionParser   - Default autowire ''
> DEBUG XBeanXmlBeanDefinitionParser   - Default dependency check ''
> DEBUG XBeanXmlBeanDefinitionParser   - Could not find resource:
> META-INF/services/org/apache/xbean/spring/http/activemq.org/config/1.0/broker
> DEBUG XBeanXmlBeanDefinitionParser   - Neither XML 'id' nor 'name' specified
> - using generated bean name [org.apache.activemq.xbean.XBeanBrokerService]
> DEBUG XBeanXmlBeanDefinitionParser   - Could not find resource:
> META-INF/services/org/apache/xbean/spring/http/activemq.org/config/1.0/transportConnector
> DEBUG XBeanXmlBeanDefinitionParser   - No XML 'id' specified - using
> 'default' as bean name and [] as aliases
> DEBUG XBeanXmlBeanDefinitionParser   - Could not find resource:
> META-INF/services/org/apache/xbean/spring/http/activemq.org/config/1.0/ref
> ERROR: java.lang.RuntimeException: Failed to execute start task. Reason:
> org.springframework.beans.factory.BeanDefinitionStoreException: Error
> registering bean with name '' defined in class path resource [activemq.xml]:
> Bean class [ref] not found; nested exception is
> java.lang.ClassNotFoundException: ref
> ERROR: java.lang.Exception:
> org.springframework.beans.factory.BeanDefinitionStoreException: Error
> registering bean with name '' defined in class path resource [activemq.xml]:
> Bean class [ref] not found; nested exception is
> java.lang.ClassNotFoundException: ref
>
> --
> View this message in context: http://www.nabble.com/Embedded-broker-with-Spring-%3A-java.lang.ClassCastException-tf1883713.html#a5165926
> Sent from the ActiveMQ - User forum at Nabble.com.
>
>


-- 

James
-------
http://radio.weblogs.com/0112098/

Mime
View raw message