activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Javier Leyba" <xle...@gmail.com>
Subject Network of brokers problem
Date Wed, 26 Jul 2006 10:38:25 GMT
Hi

I'm having a big problem with my scenario to connect a network of brokers.

I' ve two server (S1 and S2). Each one is running a master broker and
a slave broker. I want to have a network of brokers.

Then, for S1 master I did:

<networkConnectors>
        <networkConnector name="default"
uri="static://(tcp://S1:62001,tcp://S2:62006,tcp://S2:62008)"
failover="true" dynamicOnly="false" />
    </networkConnectors>


Why ? I need to connect my S1 master to S2 master (tcp://S2:62006) but
if S2 master fails, his slave will take control so I´ll need a
connection to him (tcp://S2:62008).


in my S1 slave I did it in the same way

<networkConnectors>
        <networkConnector name="default"
uri="static://(tcp://S1:62003,tcp://S2:62006,tcp://S2:62008)"
failover="true" dynamicOnly="false" />
    </networkConnectors>


and I did it in the same way for S2 master and slave.

Then I configured my clients with this:

broker.url=failover://(tcp://S1:62002,tcp://S1:62004,tcp://S2:62006,tcp://S2:62008)?randomize=false&connectionTimeout=20000&soTimeout=10000&wireFormat.maxInactivityDuration=20000

So my clients will try to connect to S1 master if it fails will try to
S1 slave if it fails will try to S2 master and so on.

After some tests, all my well planned scenario didn´t worked...

Is my way the right way to do this ?

Could somebody clarify this matter ?

Thanks in advance




-- 
Javier Leyba
Barcelona - Spain
http://blog.leyba.com.ar

Mime
View raw message