activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul French <paul.fre...@frenchiesystems.com>
Subject Re: Simple JMS outbound program never exits
Date Fri, 28 Jul 2006 13:11:19 GMT

Apologies James, PooledConnectionFactory does work okay. I had to change the
destroy-method specified in the spring from destroy to stop for the
PooledConnectionFactory .

The following does not work and the client program hangs.........

  <bean id="connectionFactory"
class="org.springframework.jms.connection.SingleConnectionFactory"
destroy-method="destroy">
    <property name="targetConnectionFactory">
      <bean class="org.apache.activemq.ActiveMQConnectionFactory">
        <property name="brokerURL" value="tcp://localhost:61616" />
        <property name="useAsyncSend"><value>TRUE</value></property>
   
      </bean>
    </property>
  </bean>

The following does work and the client program exits okay..........

  <bean id="connectionFactory"
class="org.apache.activemq.pool.PooledConnectionFactory"
destroy-method="stop">
    <property name="connectionFactory">
      <bean class="org.apache.activemq.ActiveMQConnectionFactory">
        <property name="brokerURL">
          <value>tcp://localhost:61616</value>
        </property>
        <property name="useAsyncSend"><value>TRUE</value></property>
   
      </bean>
    </property>
  </bean>

No idea why but I'll post on Spring forum. Thanks.
-- 
View this message in context: http://www.nabble.com/Simple-JMS-outbound-program-never-exits-tf2014746.html#a5539343
Sent from the ActiveMQ - User forum at Nabble.com.


Mime
View raw message