activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jcarreira <jcarre...@gmail.com>
Subject ActiveMQ with Spring 2.0?
Date Thu, 27 Jul 2006 18:53:05 GMT

Anyone using ActiveMQ 4.0.1 with Spring 2.0 ?

I've found that the XBean configuration isn't usable, since it apparently
depends on an old version of Spring. Here's the error:

org.springframework.beans.factory.BeanCreationException: Error creating bean
with name 'broker' defined in class path resource [jmsContext.xml]:
Invocation of init method failed; nested exception is
java.lang.NoClassDefFoundError:
org/springframework/beans/factory/xml/DefaultXmlBeanDefinitionParser
Caused by: 
java.lang.NoClassDefFoundError:
org/springframework/beans/factory/xml/DefaultXmlBeanDefinitionParser
	at
org.apache.xbean.spring.context.ResourceXmlApplicationContext.loadBeanDefinitions(ResourceXmlApplicationContext.java:87)
	at
org.springframework.context.support.AbstractRefreshableApplicationContext.refreshBeanFactory(AbstractRefreshableApplicationContext.java:89)
	at
org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:283)
	at
org.apache.xbean.spring.context.ResourceXmlApplicationContext.<init>(ResourceXmlApplicationContext.java:64)
	at
org.apache.xbean.spring.context.ResourceXmlApplicationContext.<init>(ResourceXmlApplicationContext.java:52)

Now, since I can't directly bind the "peer://" protocol on a BrokerService,
and the BrokerFactoryBean only takes a config location to find the Xbean XML
configuration, I'm stuck I guess... Probably have to build my own
FactoryBean or something, which means more delays getting set up...
-- 
View this message in context: http://www.nabble.com/ActiveMQ-with-Spring-2.0--tf2011356.html#a5527075
Sent from the ActiveMQ - User forum at Nabble.com.


Mime
View raw message