activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From DavidField <>
Subject Problems with Failover - replication of messages
Date Wed, 26 Jul 2006 17:01:19 GMT

I'm using ActiveMQ  4.0.1 and Mule 1.3-rc4.

I have two instances of ActiveMQ, one on tcp://localhost:61616 and another
on tcp://localhost:61617. 
I have set failover on by by the following :
          <networkConnector name="default" uri="multicast://default"/>
          <networkConnector name="host1 and host2" 

In the other ActiveMQ config, I reverse the order of the network connectors.

In Spring and Mule, the brokerURL:  is

What I want to achieve is to have messages received (by Mule) even if one of
the two instances of ActiveMQ is down. However, I find the following:
* The message will be persisted to the datastore when either ActiveMQ
instance is up - good, as nothing gets lots.
* Messages appear to be sent in turn to one of the two instances, and if a
particular instance is not up then the message will still be persisted but
not sent immediately - bad, I want them all sent straight away.
* Stopping or starting an instance will result in unsent messages being sent
- bad.
* The same message can be sent multiple times, either when both instances or
up (rare) or when an instance is either stopped or started (usual) - very

Any help is mighty appreciated!

View this message in context:
Sent from the ActiveMQ - User forum at

View raw message