activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ohad <o...@eng.tau.ac.il>
Subject activemq clients all hang
Date Sun, 16 Jul 2006 13:38:04 GMT

Hi All
I am developing a high load multi-process application which is sending a
fairly large amount of messages . I am using version 4.0.1 and those
features :
1.Connections are standard, non durable, non auto-reconnect.
2.sessions are non transactional , AutoAcknowledge
3.temporary queues are created one for each connection , and usually a
process has one 
4.JMSConnection instance and multiple session objects.
5. I am using the ActiveMQConnection.destroyDestination(...)  function
sometimes to destroy destinations that won't be used any more

The processes work fine for 3-4 hours , and then , i experience those
symptoms :
1. every MessageProducer.send() function hangs and doesn't return
2. Queues are not being emptied : i have a code that browses the queue ,
find the number of messages out of it , and the makes a receive() function
for every message. The queue is not empty even after the messages are
consumed.
3. memory consumption is normal for all i know.

I haven't compiled a juint test to recreate it , but it may be the only way
to handle this problem... 
Any idea anyone ?



-- 
View this message in context: http://www.nabble.com/activemq-clients-all-hang-tf1950608.html#a5348918
Sent from the ActiveMQ - User forum at Nabble.com.


Mime
View raw message