activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sgoyette <st...@goyettefamily.com>
Subject Re: NoClassDefFoundError ActiveMQConnectionFactory
Date Fri, 07 Jul 2006 22:18:25 GMT

Hi,

If I add the incubator-activemq-4.0.1.jar to the orion/lib directory then
yes this will allow me to get past this specific error...unfortunately it
causes other problems and isn't really an optimal way to go.

The problem I run into when doing this is that I wrap my specific message
objects inside of an ObjectMessage and when I attempt to get the object from
the message deserialization fails with:

javax.jms.JMSException: Failed to build body from bytes. Reason:
java.io.IOException: ca.intuit.jms.message.LoginMessage

This is a very non-informative message as it's really wrapping a
ClassNotFoundException and then throwing the IOException.  When I trace into
the source this is the root cause of this specific issue:

java.lang.ClassNotFoundException: ca.intuit.jms.message.LoginMessage

So it would seem that the class loader on the ActiveMQ side of things
doesn't know anything about the LoginMessage object that the message
contains.  I would think this is specifically related to the fact that the
ActiveMQ jar file is being loaded inside of the Orion container.

So I'm not sure what to do from here.  

I tried making sure that the backport-util-concurrent jar is being included
and when I look through things the root exception is :
java.lang.NoClassDefFoundError:
org/apache/activeio/util/ByteArrayInputStream
but as per the previous class path dump the library (activeio-core) is in
there and still is.

Any other ideas?  I really appreciate any and all pointers you or anyone
might have.

Thanks,

Steve


-- 
View this message in context: http://www.nabble.com/NoClassDefFoundError-ActiveMQConnectionFactory-tf1897757.html#a5225493
Sent from the ActiveMQ - User forum at Nabble.com.


Mime
View raw message