activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bbernard <bbernardi...@yahoo.com>
Subject Re: AW: AW: Cannot get SSL working
Date Wed, 05 Jul 2006 10:05:12 GMT

Hi all,

While using ActiveMQ 4.0, I was having issue with SSL connection closed,
though as Mike pointed out the message actualy get sent & consumed OK. Then
I tried to upgrade with version 4.0.1. I replaced incubator-activemq-4.0.jar
with incubator-activemq.4.0.1.jar in both side (broker) and client  side.

My activemq.bat file was modified on this line:
if "%ACTIVEMQ_OPTS%" == "" set ACTIVEMQ_OPTS=-Xmx512M
-Dorg.apache.activemq.UseDedicatedTaskRunner=true
-Dderby.system.home="..\data" -Dderby.storage.fileSyncTransactionLog=true
-Dcom.sun.management.jmxremote -Djavax.net.ssl.keyStore=..\broker.ks
-Djavax.net.ssl.keyStorePassword="secret"
-Djavax.net.ssl.trustStore=broker.ts

Running the sample without SSL is OK. Any idea why this is happening?

Now I got this exception instead (broker side):
---------------------------------------------------------------------------------------------------------------
D:kangoroo-2021-1152092300346-1:0) started
Exception in thread "ActiveMQ Transport: tcp:///127.0.0.1:2027"
java.lang.Illega
lArgumentException: Invalid version: 67174528, could not load
org.apache.activem
q.openwire.v67174528.MarshallerFactory
        at
org.apache.activemq.openwire.OpenWireFormat.setVersion(OpenWireFormat
.java:329)
        at
org.apache.activemq.openwire.OpenWireFormat.renegociatWireFormat(Open
WireFormat.java:569)
        at
org.apache.activemq.transport.WireFormatNegotiator.onCommand(WireForm
atNegotiator.java:100)
        at
org.apache.activemq.transport.InactivityMonitor.onCommand(InactivityM
onitor.java:122)
        at
org.apache.activemq.transport.TransportSupport.doConsume(TransportSup
port.java:87)
        at
org.apache.activemq.transport.tcp.TcpTransport.run(TcpTransport.java:
143)
        at java.lang.Thread.run(Thread.java:595)
Caused by: java.lang.ClassNotFoundException:
org.apache.activemq.openwire.v67174
528.MarshallerFactory
        at
org.apache.activemq.util.ClassLoading.loadClass(ClassLoading.java:104
)
        at
org.apache.activemq.openwire.OpenWireFormat.setVersion(OpenWireFormat
.java:327)
        ... 6 more

----------------------------------------------------------------------------------------------------------------------

and in client side i got this excepton:

----------------------------------------------------------------------------------------------------------------------
javax.jms.JMSException: Could not connect to broker URL:
ssl://localhost:61616. Reason: javax.net.ssl.SSLException: Unrecognized SSL
message, plaintext connection?
        at
org.apache.activemq.util.JMSExceptionSupport.create(JMSExceptionSupport.java:32)
        at
org.apache.activemq.ActiveMQConnectionFactory.createActiveMQConnection(ActiveMQConnectionFactory.java:252)
        at
org.apache.activemq.ActiveMQConnectionFactory.createActiveMQConnection(ActiveMQConnectionFactory.java:211)
        at
org.apache.activemq.ActiveMQConnectionFactory.createConnection(ActiveMQConnectionFactory.java:158)
        at
com.ic.ntn.message.MsgSupport.createConnection(MsgSupport.java:59)
        at com.ic.ntn.message.MsgConsumer.run(MsgConsumer.java:89)
        at com.ic.ntn.message.MsgConsumer.main(MsgConsumer.java:79)
Caused by: javax.net.ssl.SSLException: Unrecognized SSL message, plaintext
connection?
        at
com.sun.net.ssl.internal.ssl.InputRecord.handleUnknownRecord(InputRecord.java:525)
        at
com.sun.net.ssl.internal.ssl.InputRecord.read(InputRecord.java:355)
        at
com.sun.net.ssl.internal.ssl.SSLSocketImpl.readRecord(SSLSocketImpl.java:723)
        at
com.sun.net.ssl.internal.ssl.SSLSocketImpl.performInitialHandshake(SSLSocketImpl.java:1030)
        at
com.sun.net.ssl.internal.ssl.SSLSocketImpl.writeRecord(SSLSocketImpl.java:622)
        at
com.sun.net.ssl.internal.ssl.AppOutputStream.write(AppOutputStream.java:59)
        at
org.apache.activemq.transport.tcp.TcpBufferedOutputStream.flush(TcpBufferedOutputStream.java:108)
        at java.io.DataOutputStream.flush(DataOutputStream.java:106)
        at
org.apache.activemq.transport.tcp.TcpTransport.oneway(TcpTransport.java:125)
        at
org.apache.activemq.transport.InactivityMonitor.oneway(InactivityMonitor.java:141)
        at
org.apache.activemq.transport.WireFormatNegotiator.sendWireFormat(WireFormatNegotiator.java:128)
        at
org.apache.activemq.transport.WireFormatNegotiator.start(WireFormatNegotiator.java:64)
        at
org.apache.activemq.transport.TransportFilter.start(TransportFilter.java:52)
        at
org.apache.activemq.transport.TransportFilter.start(TransportFilter.java:52)
        at
org.apache.activemq.ActiveMQConnectionFactory.createActiveMQConnection(ActiveMQConnectionFactory.java:241)
        ... 5 more
-- 
View this message in context: http://www.nabble.com/Cannot-get-SSL-working-tf1689166.html#a5178921
Sent from the ActiveMQ - User forum at Nabble.com.


Mime
View raw message