activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tony Bonghi <tonybon...@yahoo.com>
Subject Does AMQ 4.0.1 embedded broker work?
Date Tue, 27 Jun 2006 17:13:37 GMT

I am a 3.2 user and I'm attempting to upgrade to 4.0.1 with no success. In
3.2, I had a clustered embedded broker setup working. I have been unable to
do this with 4.0.1. I read a lot of info on this and seen a bunch of posts,
so I'm assuming this does work. I am attempting to use a static list of
networkConnectors. I am getting SocketException errors when the machines
attempt to connect to each other.

I would apprieciate any help with this. 

Here's my configuration:

-----------------------------------------------------------------------------------------------
activemq-broker.xml -- For Server B
-----------------------------------------------------------------------------------------------
<beans>
        <broker persistent="false" useJmx="false"
xmlns="http://activemq.org/config/1.0">
                <transportConnectors>
                        <transportConnector uri="tcp://localhost:61616" />
                </transportConnectors>
                <networkConnectors>
                        <networkConnector uri="static:(tcp://A:61616)"
failover="true" />
                </networkConnectors>
                <persistenceAdapter>
                        <memoryPersistenceAdapter />
                </persistenceAdapter>
        </broker>
</beans>
-----------------------------------------------------------------------------------------------
activemq-broker.xml -- For Server A
-----------------------------------------------------------------------------------------------
<beans>
        <broker persistent="false" useJmx="false"
xmlns="http://activemq.org/config/1.0">
                <transportConnectors>
                        <transportConnector uri="tcp://localhost:61616" />
                </transportConnectors>
                <networkConnectors>
                        <networkConnector uri="static:(tcp://B:61616)"
failover="true" />
                </networkConnectors>
                <persistenceAdapter>
                        <memoryPersistenceAdapter />
                </persistenceAdapter>
        </broker>
</beans>

Thanks,
Tony
-- 
View this message in context: http://www.nabble.com/Does-AMQ-4.0.1-embedded-broker-work--tf1856638.html#a5070142
Sent from the ActiveMQ - User forum at Nabble.com.


Mime
View raw message