activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ENP <prokop...@stc.donpac.ru>
Subject Persistance problems
Date Fri, 02 Jun 2006 11:35:43 GMT

I have incubator-activemq-4.0 with config:

<beans xmlns="http://activemq.org/config/1.0">
  <broker useJmx="true">
    <persistenceAdapter>
      <journaledJDBC journalLogFiles="5" dataDirectory="../activemq-data"/>
    </persistenceAdapter>
    <transportConnectors>
       <transportConnector name="default" uri="tcp://localhost:61616"/>
    </transportConnectors>
  </broker>
</beans>

After running with code:

ActiveMQConnection connection = ActiveMQConnection.makeConnection(); 
connection.start();
Session session = connection.createSession(false, Session.AUTO_ACKNOWLEDGE);
Destination destination = session.createTopic("monitoring.m1");
MessageProducer producer = session.createProducer(destination);
String text = "Hello world! From: " + Thread.currentThread().getName();
TextMessage message = session.createTextMessage(text);
System.out.println("Sent message: "+ message.hashCode() + " : " +
Thread.currentThread().getName());
producer.send(message);
session.close();
connection.close();

I see new message via JMX (I use jManage)

After restarting AMQ I can't see this message and I can't see topic
"monitoring.m1"!

Why can it be?
--
View this message in context: http://www.nabble.com/Persistance-problems-t1722163.html#a4678101
Sent from the ActiveMQ - User forum at Nabble.com.


Mime
View raw message