activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From agrabil <greg.ra...@ins.com>
Subject Need help with JMS Bridge
Date Thu, 01 Jun 2006 16:46:37 GMT

Hello,
Sorry for the re-post of this question, but I would really appreciate any
help.  If this is the wrong place to ask this question, please let me know. 
I am using activemq-4.0 and JDK 5.0.

I'm attempting to setup a bridged configuration where messages sent to the
queue called MyQueue on an ActiveMQ broker are sent to a SwiftMQ broker
using the Jms to Jms bridge.  The name of the queue in SwiftMQ is actually
MyQueue@router.  Here is my configuration:

  <broker useJmx="true">
 
 
    <persistenceAdapter>
      <journaledJDBC journalLogFiles="5" dataDirectory="../activemq-data"/>
    </persistenceAdapter>
 
    <transportConnectors>
       <transportConnector name="default" uri="tcp://localhost:61616"
discoveryUri="multicast://default"/>
       <transportConnector name="stomp"   uri="stomp://localhost:61613"/>
    </transportConnectors>
   
    <networkConnectors>
      <!-- by default just auto discover the other brokers -->
      <networkConnector name="default" uri="multicast://default"/>
    </networkConnectors>

    <jmsBridgeConnectors>
       <jmsQueueConnector outboundQueueConnectionFactory="#remoteFactory">
           <outboundQueueBridges>
                <outboundQueueBridge outboundQueueName="MyQueue@router">
                </outboundQueueBridge>
           </outboundQueueBridges>
       </jmsQueueConnector>
    </jmsBridgeConnectors>
   
  </broker>
 
  <bean id="remoteFactory" class="com.swiftmq.jms.ConnectionFactoryImpl">
          <constructor-arg value="com.swiftmq.net.PlainSocketFactory"/>
          <constructor-arg value="localhost"/>
          <constructor-arg value="4001"/>
          <constructor-arg value="60000"/>
  </bean>


The connection is established from ActiveMQ to SwiftMQ, but no messages ever
get sent to the SwiftMQ provider.  Ideally, I would like to filter which
messages are forwarded to SwiftMQ, but at this point I'd be happy with _any_
messages being sent.  However, it is not clear where I indicate which
ActiveMQ queue I want "bridged" to what SwiftMQ queue.  Any help with this
type of configuration would be greatly appreciated.

Thank you,
Greg Rabil


--
View this message in context: http://www.nabble.com/Need+help+with+JMS+Bridge-t1717876.html#a4665519
Sent from the ActiveMQ - User forum at Nabble.com.


Mime
View raw message