activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gerdes, Mike" <mike.ger...@airbus.com>
Subject AW: JMX does not start
Date Thu, 15 Jun 2006 11:21:11 GMT

hi,

what is the error message that you get? Maybe the port is already used.

-----Urspr√ľngliche Nachricht-----
Von: Dirk Roscher [mailto:Dirk.Roscher@dai-labor.de]
Gesendet: Donnerstag, 15. Juni 2006 12:23
An: activemq-users@geronimo.apache.org
Betreff: JMX does not start


Hello,

i use following xml config file:

<beans>



  <broker useJmx="true" xmlns="http://activemq.org/config/1.0">



    <!--persistenceAdapter>

      <journaledJDBC journalLogFiles="5" dataDirectory="foo" />

    </persistenceAdapter -->



    <managementContext>

               <managementContext connectorPort="1099"
jmxDomainName="com.example"/>

            </managementContext>



    <transportConnectors>

      <transportConnector uri="tcp://localhost:61616" />

    </transportConnectors>

     

  </broker>



</beans>



And following bean in spring:

<bean id="broker" class="org.apache.activemq.xbean.BrokerFactoryBean">

        <property name="config" value="classpath:activemq.xml"/>

        <property name="start" value="true"/>

</bean>



But when I start the broker the jmx part does not start too.

What is my mistake?

Thanks.








This e-mail is intended only for the above addressee. It may contain
privileged information. If you are not the addressee you must not copy,
distribute, disclose or use any of the information in it. If you have
received it in error please delete it and immediately notify the sender.
Security Notice: all e-mail, sent to or from this address, may be
accessed by someone other than the recipient, for system management and
security reasons. This access is controlled under Regulation of
Investigatory Powers Act 2000, Lawful Business Practises.

Mime
View raw message