activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Strachan" <james.strac...@gmail.com>
Subject Re: Maven2
Date Wed, 24 May 2006 10:50:47 GMT
BTW did you use 2.0.4 of maven to build activemq?

On 5/23/06, Dirk Roscher <Dirk.Roscher@dai-labor.de> wrote:
> Hi,
> i can build activemq with maven2. But the resulting pom in the repository has still curious
version numbers. Maven cannot resolve them when I use activemq in a project. E.g.: Reason:
Error getting POM for 'activemq:jmdns' from the repository: Error transferring file activemq:jmdns:pom:${jmdns_version}.
> Does anybody know how to solve this?
> Thanks,
> Dirk
>
> > -----Urspr√ľngliche Nachricht-----
> > Von: Fritz Oconer [mailto:foconer@exist.com]
> > Gesendet: Freitag, 19. Mai 2006 03:09
> > An: activemq-users@geronimo.apache.org
> > Betreff: Re: Maven2
> >
> > Hi Dirk,
> >
> > > Hi,
> > > how can i use activemq with maven2? The version on ibiblio has curious
> > > version numbers for the dependencies. Maven complains that many
> > dependencies
> > > poms are not version 4 and therefore finds not all dependencies needed.
> > > But I look at some of them and they are version 4.
> >
> > This happens when the build is trying to download a dependency from a
> > repository that are still in maven 1 format or in maven 2 case, legacy
> > repositories. It will still download the dependency but it prints out a
> > warning (something like " POM for ... is invalid... Reason: Not a v4.0.0
> > POM..") and then creates a default pom, it should look some like:
> >
> > <project>
> >   <modelVersion>4.0.0</modelVersion>
> >   <groupId>cglib</groupId>
> >   <artifactId>cglib-full</artifactId>
> >   <version>2.0</version>
> > </project>
> >
> >
> > > The svn version doesn't work too.
> >
> > For the past few days, apache url with "https" is down. I've just tried it
> > and was able to checkout the source from svn. You may try one of the
> > following url for svn
> > https://svn.apache.org/repos/asf/incubator/activemq/trunk/ or
> > http://svn.apache.org/repos/asf/incubator/activemq/trunk/. If the problem
> > persist, please provide us the details of the error.
> >
> > Hope this helps,
> >
> > Regards,
> > Fritz
> >
>
>


-- 

James
-------
http://radio.weblogs.com/0112098/

Mime
View raw message