activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Strachan" <james.strac...@gmail.com>
Subject Re: createSession hangs client
Date Mon, 22 May 2006 07:39:38 GMT
There's nothing I can think of that rings a bell; it could just be the
tcp timeout is taking a long time to realise that the socket is bad.

I wonder do you get the same issue when using 4.0?

On 5/20/06, DonC <dcarder@isdl.net> wrote:
>
> I have installed activemq-4.0-M4 on a Window XP Professional and on a RHEL 4
> machine.  On the Windows machine I have compiled and run the example linked
> to the ActiveMQ JNDI Support page, using the sample jndi.properties file.
> It worked.  Sent three messages.  I changed the properties file to point at
> the linux machine:
>
> java.naming.provider.url = tcp://linux_ip:61616?trace=true
>
> When I run it, the client hangs at:
>
> session = connection.createSession(false, Session.AUTO_ACKNOWLEDGE);
>
> It doesn't throw an exception, it just hangs.  When I do netstat -an|grep
> 61616 on the Linux box it
> shows a connection was established between the two machines.  There must be
> something I'm missing here?  I'm brand new to this, any help is appreciated.
>
> Don Carder
> --
> View this message in context: http://www.nabble.com/createSession+hangs+client-t1653776.html#a4480652
> Sent from the ActiveMQ - User forum at Nabble.com.
>
>


-- 

James
-------
http://radio.weblogs.com/0112098/

Mime
View raw message