activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Charles Anthony <charles.anth...@hpdsoftware.com>
Subject Which version of ActiveMQ to use ?
Date Wed, 10 May 2006 09:46:15 GMT
Hi,


We currently have several live installations which use ActiveMQ 2.1 - (yes
2.1, no typo)

Our needs are currently very simple - a single ActiveMQ server, no
clustering, no persistency, no fail-over, no nothing. (Some of those things
would be very handy, but haven't got around to attempting to implement them
yet).

We have been getting intermittent ConcurrentModification errors from the
bowels of AMQ when sending messages - we've been  sort of tap danced around
them, since they've been so intermittent (like, once every 2 months).

They've been becoming more frequent, though, so it's now Time To Do
Something About It.

The obvious thing to do is to move to a later release of AMQ - but the
question is, Which ?

So, should it be 3.2.2 - the last official release - or the latest 4.0 RC ?
Is the RC stable ?

I don't think the answer to this question is quite as obvious as it may
appear... but then I'm happy to be wrong !

Cheers,

Charles.


___________________________________________________________
HPD Software Ltd. - Helping Business Finance Business
Email terms and conditions: www.hpdsoftware.com/disclaimer 



Mime
View raw message