activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rob Davies <rajdav...@gmail.com>
Subject Re: peer configuration
Date Mon, 01 May 2006 12:58:52 GMT
looking at the src I don't think your using the latest snaphot -  
what's the date your using ?
You can get the latest and greatest here: http://cvs.apache.org/ 
repository/incubator-activemq/distributions/

cheers,

Rob
http://rajdavies.blogspot.com/

On 1 May 2006, at 13:43, Jamie McCrindle wrote:

> any thoughts?
>
> i want to get an embedded broker with zero-conf up and running. it's
> working fine using an external broker but i really like the idea of
> being able to cluster by just starting up new copies of the app on the
> same subnet.
>
> cheers,
> j.
>
> On 4/28/06, Jamie McCrindle <jamiemccrindle@gmail.com> wrote:
>> hi,
>>
>> I'm running with the latest activemq 4.0 snapshots and i'm trying to
>> set up a couple of embedded brokers but i'm getting this error:
>>
>> [BpmScript] INFO [ActiveMQ Task]  
>> DemandForwardingBridge.serviceLocalException(33
>> 9) | Network connection between vm://broker1#6 and tcp://localhost/ 
>> 127.0.0.1:154
>> 6 shutdown: null
>> java.lang.NullPointerException
>>         at  
>> org.apache.activemq.network.DemandForwardingBridgeSupport.configureMe
>> ssage(DemandForwardingBridgeSupport.java:361)
>>         at  
>> org.apache.activemq.network.DemandForwardingBridgeSupport.serviceLoca
>> lCommand(DemandForwardingBridgeSupport.java:382)
>>         at  
>> org.apache.activemq.network.DemandForwardingBridgeSupport$1.onCommand
>> (DemandForwardingBridgeSupport.java:111)
>>         at  
>> org.apache.activemq.transport.ResponseCorrelator.onCommand(ResponseCo
>> rrelator.java:88)
>>         at org.apache.activemq.transport.TransportFilter.onCommand 
>> (TransportFilt
>> er.java:70)
>>         at org.apache.activemq.transport.vm.VMTransport.oneway 
>> (VMTransport.java:
>> 75)
>>         at org.apache.activemq.transport.MutexTransport.oneway 
>> (MutexTransport.ja
>> va:44)
>>         at org.apache.activemq.transport.ResponseCorrelator.oneway 
>> (ResponseCorre
>> lator.java:55)
>>         at org.apache.activemq.broker.TransportConnection.dispatch 
>> (TransportConn
>> ection.java:211)
>>         at  
>> org.apache.activemq.broker.AbstractConnection.processDispatch(Abstrac
>> tConnection.java:568)
>>         at org.apache.activemq.broker.AbstractConnection.iterate 
>> (AbstractConnect
>> ion.java:584)
>>         at org.apache.activemq.thread.SimpleTaskRunner.runTask 
>> (SimpleTaskRunner.
>> java:110)
>>         at org.apache.activemq.thread.SimpleTaskRunner.access$100 
>> (SimpleTaskRunn
>> er.java:25)
>>         at org.apache.activemq.thread.SimpleTaskRunner$1.run 
>> (SimpleTaskRunner.ja
>> va:43)
>>         at  
>> edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Wor
>> ker.runTask(ThreadPoolExecutor.java:650)
>>         at  
>> edu.emory.mathcs.backport.java.util.concurrent.ThreadPoolExecutor$Wor
>> ker.run(ThreadPoolExecutor.java:675)
>>         at java.lang.Thread.run(Thread.java:595)
>>
>> this is what my activemq configuration looks like:
>>
>> <!-- START SNIPPET: xbean -->
>> <beans xmlns="http://activemq.org/config/1.0">
>>
>>   <broker useJmx="true">
>>
>>     <transportConnectors>
>>        <transportConnector uri="tcp://localhost:0"
>> discoveryUri="multicast://default"/>
>>     </transportConnectors>
>>
>>     <networkConnectors>
>>       <networkConnector uri="multicast://default"/>
>>     </networkConnectors>
>>
>>     <persistenceAdapter>
>>       <memoryPersistenceAdapter/>
>>     </persistenceAdapter>
>>
>>   </broker>
>> </beans>
>>
>>
>> and this is what the spring beans config for my
>> activemqconnectionfactory looks like:
>>
>>       <bean class="org.apache.activemq.ActiveMQConnectionFactory">
>>         <constructor-arg value="peer://groupa/broker1? 
>> persistent=false"/>
>>       </bean>
>>
>> any ideas?
>>
>> Regards,
>> Jamie.
>>


Mime
View raw message