activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Cybernd <cybe...@cybernd.at>
Subject Re: ActiveMQ 4 + JBoss 4.0.4.ga
Date Thu, 25 May 2006 21:54:28 GMT

Got no error message. Thats the problem. Its quite hard to find bugs /
incompatibilities without any idea about the problem.

An mdb with AMQ 4 runs smooth with Jboss 4.0.4cr2
The same setup fails with JBoss 4.0.4ga

One issue is that jboss changed Destination and destination (D vs d), but
this has nothing todo with amq. The other thing is that the broker starts,
but the mdb running in jboss ga got connected to the default JMS and thats
the jboss implementation. So something changed with some configuration - but
no clue about it. I also dont know how to debug this issue.

Another annoying issue is that redeployment of an ear (which uses amq) leads
to unproper undeployment. So the classloader is still active which leads to
2 problems: 1) libs like jaxb2 got troubles with their classloader and 2)
there will be 2 paralell consumers of the same topic after redeployment -
the old version and the new redeployed version.

All this issues lead to developement slow downs. JBoss ga starts faster
which increases the developement speed, but the ga version does not run with
amq out of the box - so i will need to use the older version. And the
redeployment bug means that i need to restart jboss everytime.

mfg
Bernhard


--
View this message in context: http://www.nabble.com/ActiveMQ+4+%2B+JBoss+4.0.4.ga-t1674895.html#a4566922
Sent from the ActiveMQ - User forum at Nabble.com.


Mime
View raw message