activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From dontcrash <fenter_...@hotmail.com>
Subject openwire-c runs error
Date Wed, 10 May 2006 07:47:13 GMT

I downloaded activemq-4.0-RC2.zip and compiled openwire-c client code
successfully.but when i start activemq-4.0-RC2\bin\activemq and run
openwire-c client,show this error message:    "Exception in thread
"tcp:///127.0.0.1:1107" java.lang.IllegalArgumentException:Invalid version:
1358954496, could not load
org.apache.activemq.openwire.v1358954496.MarshallerFactory at
org.apache.activemq.openwire.OpenWireFormat.setVersion(OpenWireFormat.java:325)
at
org.apache.activemq.openwire.OpenWireFormat.renegociatWireFormat(OpenWireFormat.java:565)
at
org.apache.activemq.transport.WireFormatNegotiator.onCommand(WireFormatNegotiator.java:100)at
org.apache.activemq.transport.InactivityMonitor.onCommand(InactivityMonitor.java:122)
at
org.apache.activemq.transport.TransportSupport.doConsume(TransportSupport.java:87)
at org.apache.activemq.transport.tcp.TcpTransport.run(TcpTransport.java:139)
at java.lang.Thread.run(Unknown Source)
Caused by: java.lang.ClassNotFoundException:
org.apache.activemq.openwire.v1358954496.MarshallerFactory at
org.apache.activemq.util.ClassLoading.loadClass(ClassLoading.java:104) at
org.apache.activemq.openwire.OpenWireFormat.setVersion(OpenWireFormat.java:323)
... 6 more"

What's wrong?If anyone can help me,Thks!

--
View this message in context: http://www.nabble.com/openwire-c-runs-error-t1589914.html#a4314845
Sent from the ActiveMQ - User forum at Nabble.com.


Mime
View raw message