activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jonas Lim" <j...@exist.com>
Subject Re: ActiveMQ 4.0 JMS to JMS bridge configuration
Date Thu, 18 May 2006 11:04:35 GMT
Hi,

Try adding the configuration below :

<?xml version="1.0" encoding="UTF-8"?>
<beans xmlns="http://activemq.org/config/1.0">

  <broker useJmx="false">
    <persistenceAdapter>
            <journaledJDBC journalLogFiles="5" dataDirectory="activemq-data" 
/>
    </persistenceAdapter>

    <transportConnectors>
       <transportConnector uri="tcp://localhost:61616"/>
    </transportConnectors>

    <jmsBridgeConnectors >
       <jmsQueueConnector outboundQueueConnectionFactory="#remoteFactory">
           <outboundQueueBridges>
                <outboundQueueBridge 
outboundQueueName="org.apache.activemq.network.jms.OutboundQueueBridge"/>
           </outboundQueueBridges>
       </jmsQueueConnector>
    </jmsBridgeConnectors>

  </broker>

  <bean id="remoteFactory" 
class="org.apache.activemq.ActiveMQConnectionFactory">
    <property name="brokerURL" value="tcp://localhost:61666" />
  </bean>

 <bean id="mssql-ds" class="org.apache.commons.dbcp.BasicDataSource" 
destroy-method="close">
......
</bean>


</beans>



Regards,
Jonas



----- Original Message ----- 
From: "dineshk" <dineshk@prism.co.za>
To: <activemq-users@geronimo.apache.org>
Sent: Tuesday, May 09, 2006 4:13 PM
Subject: ActiveMQ 4.0 JMS to JMS bridge configuration


>
> Hi
>
> I'm using an ActiveMQ 4.0 broker that's embedded in a J2SE application. I
> use xbean to configure the broker and I need to configure a JMS to JMS
> bridge for an outbound queue. Please give me a suitable example JMS to JMS
> bridge configuration that will fit into the <broker>..</broker> tag. I'm
> don't know how to fit into my configuration, the example configuration
> that's on the ActiveMQ website - http://www.activemq.com/JMS+to+JMS+Bridge
>
> My configuration is as follows:
>
> <?xml version="1.0" encoding="UTF-8"?>
> <beans xmlns="http://activemq.org/config/1.0">
>
>  <broker useJmx="false">
>
>    <persistenceAdapter>
>            <journaledJDBC journalLogFiles="5" 
> dataDirectory="activemq-data"
> dataSource="#mssql-ds"/>
>    </persistenceAdapter>
>
>    <transportConnectors>
>       <transportConnector uri="tcp://localhost:61616"/>
>    </transportConnectors>
>
>  </broker>
>
>  <bean id="mssql-ds" class="org.apache.commons.dbcp.BasicDataSource"
> destroy-method="close">
>    <property name="driverClassName"
> value="com.microsoft.jdbc.sqlserver.SQLServerDriver"/>
>    <property name="url"
> value="jdbc:microsoft:sqlserver://localhost:1433;DatabaseName=DB"/>
>    <property name="username" value="username"/>
>    <property name="password" value="password"/>
>    <property name="poolPreparedStatements" value="true"/>
>  </bean>
>
>
> </beans>
>
>
> Thanks
>
> --
> View this message in context: 
> http://www.nabble.com/ActiveMQ-4.0-JMS-to-JMS-bridge-configuration-t1582854.html#a4295563
> Sent from the ActiveMQ - User forum at Nabble.com. 


Mime
View raw message