activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Strachan" <james.strac...@gmail.com>
Subject Re: Setting SSL timeout value
Date Tue, 18 Apr 2006 21:22:21 GMT
BTW I could tell this as the 'ssl' transport no longer uses ActiveIO...

java.lang.IllegalArgumentException.<init>(IllegalArgumentException.java:36)
       at
org.apache.activemq.transport.activeio.ActiveIOTransportFactory.doConnect(ActiveIOTransportFactory.java:76)


On 4/18/06, James Strachan <james.strachan@gmail.com> wrote:
> Ah - I think the TCP connection parameters only work with fairly
> recent releases of ActiveMQ; e.g. it should work if you try 4.0-RC3
>
> On 4/18/06, Jason P <cobraconn@yahoo.com> wrote:
> >
> > Thanks for the reply James,
> >
> > I took a look at the TCP Transport Reference and modified my code to include
> > the timeout parameter but now I'm getting some exceptions during the
> > connection attempt.  When I add in the soTimeout Transport Option I get the
> > following error:
> >
> > javax.jms.JMSException: Could not connect to broker URL:
> > ssl://10.0.1.9:3066?soTimeout=9000. Reason:
> > java.lang.IllegalArgumentException: Invalid connect parameters:
> > {soTimeout=9000}
> >         at java.lang.Throwable.<init>(Throwable.java:195)
> >         at java.lang.Exception.<init>(Exception.java:41)
> >         at javax.jms.JMSException.<init>(JMSException.java:35)
> >         at javax.jms.JMSException.<init>(JMSException.java:41)
> >         at
> > org.apache.activemq.util.JMSExceptionSupport.create(JMSExceptionSupport.java:32)
> >         at
> > org.apache.activemq.ActiveMQConnectionFactory.createActiveMQConnection(ActiveMQConnectionFactory.java:258)
> >         at
> > org.apache.activemq.ActiveMQConnectionFactory.createConnection(ActiveMQConnectionFactory.java:155)
> >         ... 3 more
> > Caused by: java.lang.IllegalArgumentException: Invalid connect parameters:
> > {soTimeout=9000}
> >         at java.lang.Throwable.<init>(Throwable.java:195)
> >         at java.lang.Exception.<init>(Exception.java:41)
> >         at java.lang.RuntimeException.<init>(RuntimeException.java:43)
> >         at
> > java.lang.IllegalArgumentException.<init>(IllegalArgumentException.java:36)
> >         at
> > org.apache.activemq.transport.activeio.ActiveIOTransportFactory.doConnect(ActiveIOTransportFactory.java:76)
> >         at
> > org.apache.activemq.transport.TransportFactory.connect(TransportFactory.java:84)
> >         at
> > org.apache.activemq.ActiveMQConnectionFactory.createActiveMQConnection(ActiveMQConnectionFactory.java:210)
> >         ... 5 more
> >
> > I then tried to connect using the connectionTimeout Transport Option and
> > received a similar exception:
> >
> > javax.jms.JMSException: Could not connect to broker URL:
> > ssl://10.0.1.9:3066?connectionTimeout=9000. Reason:
> > java.lang.IllegalArgumentException: Invalid connect parameters:
> > {connectionTimeout=9000}
> >         at java.lang.Throwable.<init>(Throwable.java:195)
> >         at java.lang.Exception.<init>(Exception.java:41)
> >         at javax.jms.JMSException.<init>(JMSException.java:35)
> >         at javax.jms.JMSException.<init>(JMSException.java:41)
> >         at
> > org.apache.activemq.util.JMSExceptionSupport.create(JMSExceptionSupport.java:32)
> >         at
> > org.apache.activemq.ActiveMQConnectionFactory.createActiveMQConnection(ActiveMQConnectionFactory.java:258)
> >         at
> > org.apache.activemq.ActiveMQConnectionFactory.createConnection(ActiveMQConnectionFactory.java:155)
> >         at
> > com.powertech.cm.qcom.client.CMRequestSender.connect(CMRequestSender.java:210)
> >         at
> > com.powertech.cm.qcom.client.CMClientCommunicator.init(CMClientCommunicator.java:225)
> >         at
> > com.powertech.cm.qcom.client.CMClientCommunicator.<init>(CMClientCommunicator.java:187)
> >         at
> > com.powertech.cm.qcom.client.CMClientCommunicator.main(CMClientCommunicator.java:4355)
> >  Caused by: java.lang.IllegalArgumentException: Invalid connect parameters:
> > {connectionTimeout=9000}
> >         at java.lang.Throwable.<init>(Throwable.java:195)
> >         at java.lang.Exception.<init>(Exception.java:41)
> >         at java.lang.RuntimeException.<init>(RuntimeException.java:43)
> >         at
> > java.lang.IllegalArgumentException.<init>(IllegalArgumentException.java:36)
> >         at
> > org.apache.activemq.transport.activeio.ActiveIOTransportFactory.doConnect(ActiveIOTransportFactory.java:76)
> >         at
> > org.apache.activemq.transport.TransportFactory.connect(TransportFactory.java:84)
> >         at
> > org.apache.activemq.ActiveMQConnectionFactory.createActiveMQConnection(ActiveMQConnectionFactory.java:210)
> >         ... 5 more
> >
> > I'm using the ActiveMQ 4.0-M4 source download which I modified in Eclipse
> > and built using Maven (maven -Dmaven.test.skip=true).  Do the Transport
> > Options remain the same from 3.x to 4.x?
> >
> >
> >
> > --
> > View this message in context: http://www.nabble.com/Setting-SSL-timeout-value-t1451458.html#a3971182
> > Sent from the ActiveMQ - User forum at Nabble.com.
> >
> >
>
>
> --
>
> James
> -------
> http://radio.weblogs.com/0112098/
>


--

James
-------
http://radio.weblogs.com/0112098/

Mime
View raw message