activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hiram Chirino" <hi...@hiramchirino.com>
Subject Re: create connnection hanging
Date Thu, 27 Apr 2006 13:41:23 GMT
Do you have the firewall enabled?

On 4/27/06, necrosus <kris.allsop@gmail.com> wrote:
>
> Not sure i am missing something simple.
>
> I am running activemq on linux (Centos 4.3).. (tried java 1.4 and 5)
> Basically i just started up the default configuration of activemq (using
> /bin/activemq). It starts fine.
>
> Then i wanted to run a simple java program to connect to activemq so start
> playing with queues and messages and the like.
>
> using the code:
> ActiveMQConnectionFactory mqFactory = new
> ActiveMQConnectionFactory("tcp://localhost:61616");
> Connection connection = mqFactory.createConnection();
> Session session connection.createSession(true, Session.AUTO_ACKNOWLEDGE);
> etc
>
> Anything after createConnection doesnt get excuted and the client hangs. On
> activemq tI can see the connection being created.
> DEBUG TcpTransport                   - TCP consumer thread starting
>
> But then nothing happens until i stop the client running and it gives the
> EOF exception.
>
> Am i missing something obvious? I dont understand what is going on exactly.
> It just seesm i cant get beyond createConnection
> --
> View this message in context: http://www.nabble.com/create-connnection-hanging-t1517490.html#a4118708
> Sent from the ActiveMQ - User forum at Nabble.com.
>
>


--
Regards,
Hiram

Mime
View raw message