activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Litton, Tom - CEPM" <Tom.Lit...@cepm-us.com>
Subject NPE when closing
Date Fri, 28 Apr 2006 21:10:13 GMT
I'm running a broker embedded in a tomcat server.  I'm getting a NullPointerException when
the server is shut down.
 
The exception stack trace is:
java.lang.NullPointerException
        at org.apache.activemq.ActiveMQConnection.syncSendPacket(ActiveMQConnect
ion.java:1137)
        at org.apache.activemq.ActiveMQConnection.close(ActiveMQConnection.java:
540)
 
The transport class is org.apache.activemq.transport.vm.VMTransportServer$1  It looks like
the VM transport server never responds to the request to shutdown.  The call to Transport.request
times out and returns null.
 
Has anyone seen this problem before?  Is it a problem with the way i'm setting up the VM transport?

My transport configuration is:
    <transportConnectors>
       <transportConnector name="default" uri="vm://localhost" />
       <transportConnector name="external" uri="tcp://localhost:61616" />
    </transportConnectors>
 
Thanks for any help you can provide.
 
Tom

 


----------------------------------------------------------------------
The information contained in this transmission is intended only for
the personal and confidential use of the designated recipients named
herein.  If the reader of this transmission is not the intended
recipient or an agent responsible for delivering it to the intended
recipient, you are hereby notified that you have received this
transmission in error, and that any review, dissemination,
distribution, or copying of this transmission is strictly prohibited.
If you have received this communication in error, please notify the
sender and return and delete the original transmission immediately.
Thank you.


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message