activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Dillon <jason.dil...@paybytouch.com>
Subject 'NameNotFoundException: jmxrmi' when running bin/* scripts
Date Tue, 25 Apr 2006 23:03:44 GMT
Anyone know why 'query' (or any of the other scripts) would spit out  
this error:

<snip>
./query
ACTIVEMQ_HOME: /home/j2eetck/incubator-activemq-4.0-RC3
ERROR: java.lang.RuntimeException: Failed to execute query task.  
Reason: java.io.IOException: javax.naming.NameNotFoundException: jmxrmi
ERROR: java.lang.Exception: java.io.IOException:  
javax.naming.NameNotFoundException: jmxrmi
</snip>

I've got ActiveMQ running, with 99% the default (just the TCP  
transportConnector port changed).

ActiveMQ is listening on port 1099.  lsof confirms that it is the  
ActiveMQ process that has it opened.

Google shows me this: http://jira.activemq.org/jira/browse/AMQ-509

But its not much help.

Any idea?

Might be a good idea to print a more user friendly error.  And might  
be a good idea to expose a --debug to enable lots of logging for the  
admin commands so that folks can debug anything.

Thanks,

--jason
This email and any attachment(s) thereto, are intended for the use of
the addressee(s) named herein and may contain legally privileged and or
confidential information under applicable law. If you are not the
intended recipient of this e-mail, you are hereby notified any
dissemination, distribution or copying of this email, and any attachment(s)
thereto, is strictly prohibited. If you have received this communication
in error, please notify the sender at 415-281-2200 or via return e-mail at
postmaster@paybytouch.com and permanently delete the original copy and 
any copy of any e-mail, and any printout thereof. Thank you for your 
cooperation.


Mime
View raw message