activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From activemquser <shawndsteph...@gmail.com>
Subject Re: ActiveMQ >m4 + JBoss
Date Thu, 13 Apr 2006 15:36:23 GMT

I got AMQ RC2 rar to work with JBoss 4.0.3SP1. There is a bug in the current
ra.xml config. ActiveMQ is not starting an embedded broker when the config
is blank as it did in previous versions. So I set BrokerXmlConf as follows.
I also deleted everything under JBOSS_HOME\data\ as this was causing the
EOFException problems mentioned in my previous post. After doing this the
rar deployed and I can telnet to 61616.

        <config-property>
            <description>
              Sets the XML configuration file used to configure the embedded
ActiveMQ broker via 
              Spring if using embedded mode.
              
              BrokerXmlConfig is the filename which is assumed to be on the
classpath unless 
              a URL is specified. So a value of foo/bar.xml would be assumed
to be on the 
              classpath whereas file:dir/file.xml would use the file system. 
              Any valid URL string is supported.              
            </description>
            <config-property-name>BrokerXmlConfig</config-property-name>
            <config-property-type>java.lang.String</config-property-type>
           
<config-property-value>xbean:broker-config.xml</config-property-value>
        </config-property>
--
View this message in context: http://www.nabble.com/ActiveMQ-%3Em4-%2B-JBoss-t1437916.html#a3902843
Sent from the ActiveMQ - User forum at Nabble.com.


Mime
View raw message