activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kuppe <ku...@360t.com>
Subject Re: MessageListener stops receiving messages from queue
Date Tue, 11 Apr 2006 05:53:09 GMT

Ok, i have done some further testing, and have the following results, this
time on the topic...

When i setup to send 100000 messages to the topic, i see that up to 32560
the MessageListener receives exactly what is sent. Then for some reason the
messages stop being received.. Then the producer sends another 2000 messages
or so (up to 34614), then it stops. When i remove the MessageListener from
the topic, all messages are sent successfully.

The purpose of my testing is really to determine the performance and
throughput of the BrokerService under different conditions as i am looking
to implement a market data BrokerService for distributing about 6500
rates/sec... Before implementing a more complicated solution, i am hoping to
establish a good prototype demonstrating the abilities of ActiveMQ.

Actually, perhaps you can explain how there might be any connection between
a publisher and a subscriber on a topic, especially when i have set the
delivery mode to NON_PERSISTENT. I would expect that a subscriber will
essentially just pick up the latest message to have been sent by the
producer and the producer would be completely decoupled from the consumer...

Again, thanks for your support in advance.

m.
--
View this message in context: http://www.nabble.com/MessageListener-stops-receiving-messages-from-queue-t1429310.html#a3855530
Sent from the ActiveMQ - User forum at Nabble.com.


Mime
View raw message