activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rob Davies <rajdav...@gmail.com>
Subject Re: Embedded Networked Brokers
Date Sat, 15 Apr 2006 06:23:35 GMT
Richard,

before RC2 the failover tag was automatically injected for networks -  
but IIRC that was changed to be consistent with the way URIs work for  
other connectors and protocols.
For your network URI could you try:

static:failover:(tcp://127.0.0.1:61616,tcp://127.0.0.1:61626)

cheers,

Rob


On 15 Apr 2006, at 02:41, Richard Maher wrote:

>
> I did post the code in a previous message. Here it is again:
>
>     public EmbeddedBroker(List<String> transportConnectors, String
> networkConnector) throws Exception {
>         brokerService.setPersistent(false);
>         brokerService.setUseJmx(false);
>
> brokerService.setTransportConnectorURIs(transportConnectors.toArray 
> (new
> String[0]));
>         if (networkConnector != null)
>             brokerService.addNetworkConnector(networkConnector);
>     }
>
> where transportConnectors is a list of URIs such as "vm://localhost",
> "tcp://localhost:61616", etc...
> and  networkConnector is
> "static://(tcp://127.0.0.1:61616,tcp://127.0.0.1:61626)".
>
> Ther problem I am having is with this URI construct
> "static://(tcp://127.0.0.1:61616,tcp://127.0.0.1:61626)". It use  
> work in M4
> but stopped working in RC2.
>
> Richard
> --
> View this message in context: http://www.nabble.com/Embedded- 
> Networked-Brokers-t1448274.html#a3925718
> Sent from the ActiveMQ - User forum at Nabble.com.
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message