activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Javier Leyba" <xle...@gmail.com>
Subject Re: Journal is already opened by this application error
Date Thu, 23 Mar 2006 14:09:34 GMT
On 3/23/06, James.Strachan <james.strachan@gmail.com> wrote:
>
>
> Which date of SNAPSHOT is it? :)

Ouch, sorry, file is dates march 16.


>
> I wonder could you post the logs so we can see the 2 brokers starting up to
> double check the configuration is working correctly and using the 2
> different directories you specified


I've configured this:

-------------------

<beans xmlns="http://activemq.org/config/1.0">

  <broker brokerName="BROKER_1" persistent="true" useJmx="true">
    <persistenceAdapter>
        <journaledJDBC journalLogFiles="5"
dataDirectory="/home/jcm/jl/activemq-4.0-SNAPSHOT/activemq-data"
dataSource="#mysql-ds" useJournal="true" useQuickJournal="false">
                                <adapter><bytesJDBCAdapter/></adapter>
                        </journaledJDBC>
    </persistenceAdapter>

-----------------------

As my config said I should have an activemq-data directory below
activemq-4.0-SNAPSHOT, but I noticed there are one where my config
expected to found it and one in activemq-4.0-SNAPSHOT/bin  directory.

I've deleted both, and started just one broker (the owner of above
config) and received the error message again !!!  ;(

Is normal to have two activemq-data directories ?

I've attached my log ...

Thanks in advance

J

Mime
View raw message