activemq-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jpederzolli <jpederzo...@gmail.com>
Subject 4.0RC1 Infinite loop
Date Sat, 25 Mar 2006 19:59:53 GMT

Ive been testing resends with 4.0RC1 - when I throw a runtime exception in
onMessage the messsages are getting rolledback/resent as expected, however
AMQ appears to go into an infinite loop at this point taking up 100% of the
CPU. I turned debug on and this is what is repeated:
...
[DEBUG] 2006-03-21 16:55:37,586 - org.apache.activemq.ra.ServerSessionImpl:1
(ServerSessionImpl.java:159)- run loop start
[DEBUG] 2006-03-21 16:55:37,586 - org.apache.activemq.ra.ServerSessionImpl:3
(ServerSessionImpl.java:172)- run loop end
[DEBUG] 2006-03-21 16:55:37,586 -
org.apache.activemq.ra.ServerSessionImpl:22 (ServerSessionImpl.java:172)-
run loop end
[DEBUG] 2006-03-21 16:55:37,586 -
org.apache.activemq.ra.ServerSessionImpl:11 (ServerSessionImpl.java:159)-
run loop start
[DEBUG] 2006-03-21 16:55:37,586 - org.apache.activemq.ra.ServerSessionImpl:0
(ServerSessionImpl.java:172)- run loop end
[DEBUG] 2006-03-21 16:55:37,586 -
org.apache.activemq.ra.ServerSessionImpl:17 (ServerSessionImpl.java:172)-
run loop end
[DEBUG] 2006-03-21 16:55:37,586 - org.apache.activemq.ra.ServerSessionImpl:1
(ServerSessionImpl.java:172)- run loop end 
...

This is obviously a bug, but since I cant find any other posts related to
this Im guessing its something directly related to my configuration...any
insight? Thanks
--
View this message in context: http://www.nabble.com/4.0RC1-Infinite-loop-t1342437.html#a3590392
Sent from the ActiveMQ - User forum at Nabble.com.


Mime
View raw message