activemq-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <>
Subject [jira] [Commented] (ARTEMIS-1892) Allow whitespace in <acceptor>
Date Fri, 01 Jun 2018 17:27:00 GMT


ASF GitHub Bot commented on ARTEMIS-1892:

GitHub user jbertram opened a pull request:

    ARTEMIS-1892 allow whitespace in acceptor and connector URIs


You can merge this pull request into a Git repository by running:

    $ git pull ARTEMIS-1892

Alternatively you can review and apply these changes as the patch at:

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #2120
commit b3f9f51b1d507b4dea2894aeef78fd515c0fcf4e
Author: Justin Bertram <jbertram@...>
Date:   2018-06-01T17:26:12Z

    ARTEMIS-1892 allow whitespace in acceptor and connector URIs


> Allow whitespace in <acceptor>
> ------------------------------
>                 Key: ARTEMIS-1892
>                 URL:
>             Project: ActiveMQ Artemis
>          Issue Type: New Feature
>            Reporter: Lionel Cons
>            Priority: Minor
> When tuning the acceptors, theĀ {{<acceptor>}} elements can quickly become very
long and hard to read.
> Here is an example from the default configuration:
> {code}
>   <!-- Acceptor for every supported protocol -->
>   <acceptor name="artemis">tcp://;tcpReceiveBufferSize=1048576;protocols=CORE,AMQP,STOMP,HORNETQ,MQTT,OPENWIRE;useEpoll=true;amqpCredits=1000;amqpLowCredits=300</acceptor>
> {code}
> It would be nice to be able to add whitespace to make the {{broker.xml}} easier to read
and manage. For instance:
> {code}
>   <!-- Acceptor for every supported protocol -->
>   <acceptor name="artemis">
>     tcp://
>     tcpSendBufferSize=1048576;
>     tcpReceiveBufferSize=1048576;
>     useEpoll=true;
>     amqpCredits=1000;
>     amqpLowCredits=300
>   </acceptor>
> {code}
> It seems that stripping whitespace from theĀ {{<acceptor>}} elements text should
be enough to make it work...

This message was sent by Atlassian JIRA

View raw message