activemq-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lionel Cons (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ARTEMIS-1869) Cannot consume using STOMP a message published using MQTT
Date Wed, 16 May 2018 10:14:00 GMT

    [ https://issues.apache.org/jira/browse/ARTEMIS-1869?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16477206#comment-16477206
] 

Lionel Cons commented on ARTEMIS-1869:
--------------------------------------

It seems the web console is also confused. The queue is not empty (message count > 0) but
when I click on browse it shows no messages...

> Cannot consume using STOMP a message published using MQTT
> ---------------------------------------------------------
>
>                 Key: ARTEMIS-1869
>                 URL: https://issues.apache.org/jira/browse/ARTEMIS-1869
>             Project: ActiveMQ Artemis
>          Issue Type: Bug
>            Reporter: Lionel Cons
>            Priority: Major
>
> I have a test MQTT producer that sends a message to an address. There is a queue bound
to this address and I can see the message using the web console. Message count is 1.
> I have a test STOMP consumer subscribing to this queue. It does not get the message.
> If I then start a STOMP publisher to send a message to the same address. The message
appears in the same queue. Message count is now 2.
> I then start again the STOMP consumer and it does get the STOMP published message (and
message count goes down to 1) but it does not get the MQTT published message. Why?



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message