activemq-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "clebert suconic (JIRA)" <j...@apache.org>
Subject [jira] [Reopened] (ARTEMIS-1605) RBAC back compatibility Issue in upgrading broker from 2.3
Date Mon, 30 Apr 2018 17:08:00 GMT

     [ https://issues.apache.org/jira/browse/ARTEMIS-1605?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

clebert suconic reopened ARTEMIS-1605:
--------------------------------------

> RBAC back compatibility Issue in upgrading broker from 2.3
> ----------------------------------------------------------
>
>                 Key: ARTEMIS-1605
>                 URL: https://issues.apache.org/jira/browse/ARTEMIS-1605
>             Project: ActiveMQ Artemis
>          Issue Type: Bug
>    Affects Versions: 2.5.0
>            Reporter: Michael Andre Pearce
>            Priority: Major
>             Fix For: 2.5.1
>
>
> On taking an older 2.3 broker and taking master i have noticed a simply upgrade by repointing
the artemis home, the server won't start.
>  ./bin/artemis run
> Invalid configuration URI, can't find file: management.xml
> Configuration should be specified as 'scheme:location'. Default configuration is 'xml:${ARTEMIS_INSTANCE}/etc/bootstrap.xml'
> This seems due to changes in ARTEMIS-1463 that create a new management.xml and expect
this but unfortunately is not back compatible, e.g. no handling if not present.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message