activemq-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ARTEMIS-1680) Message load balancing type isn't updated in the linked bindings when wildcards are used
Date Tue, 13 Feb 2018 15:59:00 GMT

    [ https://issues.apache.org/jira/browse/ARTEMIS-1680?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16362546#comment-16362546
] 

ASF GitHub Bot commented on ARTEMIS-1680:
-----------------------------------------

GitHub user Skiler opened a pull request:

    https://github.com/apache/activemq-artemis/pull/1869

    ARTEMIS-1680 - Message load balancing type isn't updated in the linke…

    …d bindings when wildcards are used
    
    This makes the linked address consistent  when a message is sent to a linked address and
after the wildcard address is subscribed

You can merge this pull request into a Git repository by running:

    $ git pull https://github.com/Skiler/activemq-artemis wildcard

Alternatively you can review and apply these changes as the patch at:

    https://github.com/apache/activemq-artemis/pull/1869.patch

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #1869
    
----
commit 788f817c5cc7e388ca280f03680ac925d75cd52c
Author: raul.valdoleiros <raul.valdoleiros@...>
Date:   2018-02-13T15:55:46Z

    ARTEMIS-1680 - Message load balancing type isn't updated in the linked bindings when wildcards
are used
    
    This makes the linked address consistent  when a message is sent to a linked address and
after the wildcard address is subscribed

----


> Message load balancing type isn't updated in the linked bindings when wildcards are used
> ----------------------------------------------------------------------------------------
>
>                 Key: ARTEMIS-1680
>                 URL: https://issues.apache.org/jira/browse/ARTEMIS-1680
>             Project: ActiveMQ Artemis
>          Issue Type: Bug
>            Reporter: Raul Valdoleiros
>            Priority: Blocker
>
> I added a test in the class MqttClusterWildcardTest that shows the problem.
> The problem is:
>  * Broker 1 starts
>  * Client 1 connects
>  ** subscribe a wildcard address
>  ** send data to a linked address (from the previous bullet)
>  * Broker 2 starts
>  * Client 2 connects
>  ** subscribe a wildcard address
>  ** send data to a linked address
>  * Stackoverflow error



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message