activemq-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ARTEMIS-1669) JMS message is not received when using a non-transactional JMSConnectionFactoryDefinition
Date Mon, 19 Feb 2018 07:24:00 GMT

    [ https://issues.apache.org/jira/browse/ARTEMIS-1669?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16368834#comment-16368834
] 

ASF GitHub Bot commented on ARTEMIS-1669:
-----------------------------------------

Github user JiriOndrusek commented on the issue:

    https://github.com/apache/activemq-artemis/pull/1857
  
    @jbertram Hi, thank you for pointing it out, my bad, I've fixed it to Artemis.


> JMS message is not received when using a non-transactional JMSConnectionFactoryDefinition
> -----------------------------------------------------------------------------------------
>
>                 Key: ARTEMIS-1669
>                 URL: https://issues.apache.org/jira/browse/ARTEMIS-1669
>             Project: ActiveMQ Artemis
>          Issue Type: Bug
>    Affects Versions: 1.5.5
>            Reporter: Jiri Ondrusek
>            Priority: Major
>
> When using a JMSConnectionFactoryDefinition annotation, and specifying a non transactional
connection factory, message is not being sent (or at least received by MDB). Example:
> @JMSConnectionFactoryDefinition(
>  name = "java:app/jms/nonXAconnectionFactory",
>  transactional = false,
>  properties = {
>  "connectors=in-vm",}
>  ),
> When using an MDB message isn't received. Removing "transactional" attribute makes it
work again.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message