activemq-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Justin Bertram (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ARTEMIS-1648) Messages from 1.x clients to 2.x cluster are lost when they are load balanced to nodes with matching consumers
Date Mon, 05 Feb 2018 20:56:00 GMT

    [ https://issues.apache.org/jira/browse/ARTEMIS-1648?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16352930#comment-16352930
] 

Justin Bertram commented on ARTEMIS-1648:
-----------------------------------------

There's been some other changes on master as well that I forgot about.  For compatibility
with older versions you'll need to configure the acceptor with {{anycastPrefix=jms.queue.&multicastPrefix=jms.topic.}}. 
Try that and let me know how it goes.

> Messages from 1.x clients to 2.x cluster are lost when they are load balanced to nodes
with matching consumers
> --------------------------------------------------------------------------------------------------------------
>
>                 Key: ARTEMIS-1648
>                 URL: https://issues.apache.org/jira/browse/ARTEMIS-1648
>             Project: ActiveMQ Artemis
>          Issue Type: Bug
>          Components: Broker
>    Affects Versions: 2.3.0
>            Reporter: Jarek Przygódzki
>            Priority: Major
>
> When a message from 1.x client is transfered to node in the cluster with matching consumers
(message-load-balancing=ON_DEMAND), it's moved to appropriate replication queue, forwarded
to target node and then subsequently dropped  because there aren't any matching bindings
for message address. This is because if the original message is sent to address with the jms.queue
prefix (1.x clients), than the message sent by ClusterConnectionBridge also has the prefixed
destination address and this situation is not supported.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message