activemq-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rajesh Malla (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMQ-6877) http connector - queuePrefetch=0 not working
Date Mon, 01 Jan 2018 06:03:00 GMT

    [ https://issues.apache.org/jira/browse/AMQ-6877?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16307371#comment-16307371
] 

Rajesh Malla commented on AMQ-6877:
-----------------------------------

Thank you for suggestion, we found change-set for : https://issues.apache.org/jira/browse/AMQ-6823
this is 
https://git-wip-us.apache.org/repos/asf?p=activemq.git;a=blobdiff;f=activemq-client/src/main/java/org/apache/activemq/command/MessagePull.java;h=aa5a279e071c66c53ed83d966915df6d877600e5;hp=57a25f987a1f7d7551cc705e7cf1d471271ce199;hb=eccbd75;hpb=e2eabeb1c2a8234d2763238eae8a2a143e1860a6

which is only on MessagePull.java - [ *implements TransientInitializer & override of initTransients
method* ]
so we just want to confirm whether this is the only changeset or any other ? If there are
other changes can you please share us that commit set.

> http connector - queuePrefetch=0 not working
> --------------------------------------------
>
>                 Key: AMQ-6877
>                 URL: https://issues.apache.org/jira/browse/AMQ-6877
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: activemq-camel, JMS client
>    Affects Versions: 5.12.1, 5.13.1, 5.12.3, 5.13.2
>            Reporter: Rajesh Malla
>             Fix For: 5.15.1
>
>         Attachments: SimpleJMS.java, pom.xml
>
>
> We have activemq-broker running with 5.12.1 version, attached SimpleJMS.java & pom.xml
[ uses 5.12.3 version of activemq-http, activemq-client].
> In the broker activemq.xml - we have enabled http transport connector
> <transportConnector name="http" uri="http://0.0.0.0:22001" />
> Now
> 1) in our SimpleJMS.java - if we are removing 
>          ((ActiveMQConnection) connection).getPrefetchPolicy().setQueuePrefetch(0);
>     then we are able to send & receive message successfully.
>     If we are setting QueuePrefetch to 0 then Producer is sending message where as Consumer
not receiving message :(
> same SimpleJMS with & without QueuePrefetch=0 is working properly with 5.8.0 version
& 5.15.2 latest release.
> all our activemq-http,activemq-client, broker all are in same version.
> with 5.8.0 - we used jdk 1.6
> with 5.15.2 - we used jdk 1.8
> with 5.12.3[client] -> 5.12.1[broker] we tried jdk 1.8 & jdk 1.7 but no luck.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message