activemq-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "clebert suconic (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (ARTEMIS-1466) Upgrade Node.js version to comply with GitBook 3.2.3
Date Wed, 18 Oct 2017 12:24:00 GMT

     [ https://issues.apache.org/jira/browse/ARTEMIS-1466?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

clebert suconic closed ARTEMIS-1466.
------------------------------------
    Resolution: Fixed

> Upgrade Node.js version to comply with GitBook 3.2.3
> ----------------------------------------------------
>
>                 Key: ARTEMIS-1466
>                 URL: https://issues.apache.org/jira/browse/ARTEMIS-1466
>             Project: ActiveMQ Artemis
>          Issue Type: Task
>            Reporter: Pavel Kralik
>             Fix For: 2.4.0
>
>
> Building Artemis from fresh repository, purged NPM cache and removed previous version
of GitBook with release profile. I am getting error: GitBook version 3.2.3 is corrupted.
> {code:java}
> mvn clean install -Prelease
> main:
>     [mkdir] Created dir: /home/pkralik/git/activemq-artemis-1/artemis-website/target/classes/user-manual
>      [echo] executing /home/pkralik/git/activemq-artemis-1/artemis-website/node_modules/.bin/gitbook
>      [exec] Error loading version 3.2.3: SyntaxError: Use of const in strict mode.
>      [exec]     at Module._compile (module.js:439:25)
>      [exec]     at Object.Module._extensions..js (module.js:474:10)
>      [exec]     at Module.load (module.js:356:32)
>      [exec]     at Function.Module._load (module.js:312:12)
>      [exec]     at Module.require (module.js:364:17)
>      [exec]     at require (module.js:380:17)
>      [exec]     at Object.<anonymous> (/home/pkralik/.gitbook/versions/3.2.3/node_modules/read-installed/node_modules/read-package-json/read-json.js:12:16)
>      [exec]     at Module._compile (module.js:456:26)
>      [exec]     at Object.Module._extensions..js (module.js:474:10)
>      [exec]     at Module.load (module.js:356:32)
>      [exec] 
>      [exec] GitBook Ver
>      [exec] /home/pkralik/.gitbook/versions/3.2.3/node_modules/read-installed/node_modules/read-package-json/node_modules/json-parse-better-errors/index.js:9
>      [exec]     const syntaxErr = e.message.match(/^Unexpected token.*position\s+(\d+)/i)
>      [exec]     ^^^^^
>      [exec] sion 3.2.3 is corrupted
> {code}
> GitBook 3.2.3 runs in strict mode and Node.js version (v0.10.32):
> https://github.com/apache/activemq-artemis/blob/master/artemis-website/pom.xml#L85
> must be upgraded according to this table:
> http://node.green/#ES2015-bindings-const-basic-support--strict-mode-



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message