activemq-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF subversion and git services (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMQ-6834) ClassNotFoundException when install activemq-osgi bundle with Camel 2.19.x into OSGi container
Date Sun, 15 Oct 2017 08:22:03 GMT

    [ https://issues.apache.org/jira/browse/AMQ-6834?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16205065#comment-16205065
] 

ASF subversion and git services commented on AMQ-6834:
------------------------------------------------------

Commit 98a5e55a9676f6857aefed5a0d4a364ba4920375 in activemq's branch refs/heads/master from
[~davsclaus]
[ https://git-wip-us.apache.org/repos/asf?p=activemq.git;h=98a5e55 ]

AMQ-6834: activemq-osgi should not include camel namespace in spring as they have been removed
from Camel. Only blueprint is supported


> ClassNotFoundException when install activemq-osgi bundle with Camel 2.19.x into OSGi
container
> ----------------------------------------------------------------------------------------------
>
>                 Key: AMQ-6834
>                 URL: https://issues.apache.org/jira/browse/AMQ-6834
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: OSGi/Karaf
>    Affects Versions: 5.15.0
>         Environment: Java 8
>            Reporter: Xilai Dai
>             Fix For: 5.16.0, 5.15.2
>
>
> Start karaf OSGi container, install Camel 2.19.2 and activemq-client feature (activemq-osgi
bundle), then the ClassNotFoundException is thrown:
> {code}
> 2017-10-10T10:12:30,012 | WARN  | pool-46-thread-2 | aries.blueprint.spring.Activator
  57 | 291 - org.apache.aries.blueprint.spring - 0.4.0 | Error starting extension: org.apache.activemq.activemq-osgi/5.15.0
> java.lang.ClassNotFoundException: org.apache.camel.osgi.CamelNamespaceHandler cannot
be found by org.apache.activemq.activemq-osgi_5.15.0
> 	at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:461)
[?:?]
> 	at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:372) [?:?]
> 	at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:364) [?:?]
> 	at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:161)
[?:?]
> 	at java.lang.ClassLoader.loadClass(ClassLoader.java:357) [?:?]
> 	at org.eclipse.osgi.internal.framework.EquinoxBundle.loadClass(EquinoxBundle.java:564)
[?:?]
> 	at org.apache.aries.blueprint.spring.SpringExtension.start(SpringExtension.java:64)
[291:org.apache.aries.blueprint.spring:0.4.0]
> 	at org.apache.felix.utils.extender.AbstractExtender$1.run(AbstractExtender.java:265)
[291:org.apache.aries.blueprint.spring:0.4.0]
> 	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:?]
> 	at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:?]
> 	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$201(ScheduledThreadPoolExecutor.java:180)
[?:?]
> 	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:293)
[?:?]
> 	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) [?:?]
> 	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) [?:?]
> 	at java.lang.Thread.run(Thread.java:745) [?:?]
> {code}
> From Camel 2.19.x, the camel-spring-dm feature/bundle has been totally removed, that's
why the org.apache.camel.osgi.CamelNamespaceHandler couldn't be found anymore. 
> {code}
> http\://camel.apache.org/schema/osgi=org.apache.camel.osgi.CamelNamespaceHandler
> {code}
> There is still definition above in the spring.handlers of the activemq-osgi bundle. this
may need to be removed or updated from spring.handlers.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message