activemq-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ARTEMIS-1443) When running Artemis in OSGI specifying CORE protocol causes it not to start
Date Mon, 02 Oct 2017 18:20:00 GMT

    [ https://issues.apache.org/jira/browse/ARTEMIS-1443?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16188556#comment-16188556
] 

ASF GitHub Bot commented on ARTEMIS-1443:
-----------------------------------------

Github user ryeats commented on a diff in the pull request:

    https://github.com/apache/activemq-artemis/pull/1565#discussion_r142204873
  
    --- Diff: artemis-features/src/main/resources/artemis.xml ---
    @@ -22,28 +22,68 @@ under the License.
                    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
                    xsi:schemaLocation="urn:activemq /schema/artemis-configuration.xsd">
     
    -   <jms xmlns="urn:activemq:jms">
    -      <queue name="DLQ"/>
    -      <queue name="ExpiryQueue"/>
    -   </jms>
    +   <core xmlns="urn:activemq:core" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    +         xsi:schemaLocation="urn:activemq:core ">
    +
    +      <persistence-enabled>true</persistence-enabled>
    +
    +      <!-- this could be ASYNCIO, MAPPED, NIO
    +           ASYNCIO: Linux Libaio
    +           MAPPED: mmap files
    +           NIO: Plain Java Files
    +       -->
    +      <journal-type>NIO</journal-type>
    --- End diff --
    
    Copy paste issue ill change it back to ASYNCIO. I was just copying in defaults from a
fresh install of artemis since this looked out of date let me know if thats not a good idea.


> When running Artemis in OSGI specifying CORE protocol causes it not to start
> ----------------------------------------------------------------------------
>
>                 Key: ARTEMIS-1443
>                 URL: https://issues.apache.org/jira/browse/ARTEMIS-1443
>             Project: ActiveMQ Artemis
>          Issue Type: Bug
>          Components: osgi
>    Affects Versions: 1.5.1, 2.0.0
>            Reporter: Ryan Yeats
>
> if you specify CORE in the artemis.xml artemis doesn't start and you get a message "Required
protocol was added for broker local. Still waiting for [CORE]"



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message