activemq-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Claus Ibsen (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AMQ-6817) [OSGi] Bundle activemq-http requires non-existing bundle activemq-core as Fragement-Host
Date Sun, 15 Oct 2017 08:23:00 GMT

    [ https://issues.apache.org/jira/browse/AMQ-6817?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16205066#comment-16205066
] 

Claus Ibsen commented on AMQ-6817:
----------------------------------

Isn't activemq-http deprecated?

> [OSGi] Bundle activemq-http requires non-existing bundle activemq-core as Fragement-Host
> ----------------------------------------------------------------------------------------
>
>                 Key: AMQ-6817
>                 URL: https://issues.apache.org/jira/browse/AMQ-6817
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: Transport
>    Affects Versions: 5.15.0
>         Environment: Equinox 4.5.0
>            Reporter: Sandra Parsick
>            Priority: Minor
>
> If you try to integrate activemq-http in your OSGi framework like Equinox, then you will
get the failure that bundle "org.apache.activemq.activemq-core 0.0.0" is missing. According
to the MANIFEST.MF of activemq-http, the bundle org.apache.activemq.activemq-core is needed
as fragment host. But in regards to Maven central, the last released version of activemq-core
is 5.7.0. So I think that it was missed to adjust the Manifest data of activemq-http.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message