activemq-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ARTEMIS-1355) Default config for client reconnection attempts does not match documentation
Date Thu, 17 Aug 2017 17:07:00 GMT

    [ https://issues.apache.org/jira/browse/ARTEMIS-1355?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16130833#comment-16130833
] 

ASF GitHub Bot commented on ARTEMIS-1355:
-----------------------------------------

Github user jbertram commented on the issue:

    https://github.com/apache/activemq-artemis/pull/1469
  
    So this is kind of weird.  Awhile back you sent #1438 to "correct" the doc from 0 to -1.
 Now you're sending this PR to "correct" the code from 0 to -1.
    
    As far as I can tell the original #1438 shouldn't have been merged as it was incorrectly
based on the default reconnect-attempts for *cluster-connection*.
    
    The default reconnect-attempts for a normal client connection should be 0 (which it is
currently in the code, and used to be in the doc).
    
    I believe this PR should be closed and a new one should be raised to fix what #1438 broke.


> Default config for client reconnection attempts does not match documentation
> ----------------------------------------------------------------------------
>
>                 Key: ARTEMIS-1355
>                 URL: https://issues.apache.org/jira/browse/ARTEMIS-1355
>             Project: ActiveMQ Artemis
>          Issue Type: Bug
>            Reporter: Michael Andre Pearce
>
> As per docs DEFAULT_RECONNECT_ATTEMPTS should be -1 not 0
> https://activemq.apache.org/artemis/docs/latest/client-reconnection.html
> This means by default reconnection does not occur, it should be -1 as per doc so out
the box the safer setting of reconnect is done.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message