activemq-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Patrick Vansevenant (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (AMQ-6781) The ActiveMQ Web Console doesn’t support a plus (+) sign in the ClientID
Date Tue, 01 Aug 2017 13:35:00 GMT

     [ https://issues.apache.org/jira/browse/AMQ-6781?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Patrick Vansevenant updated AMQ-6781:
-------------------------------------
    Description: 
I’m trying to use an ISO 8601 date/time as part of the ClientID. 

For example : connection.setClientID("<my unique id>|2017-08-01T09:20:18.936+03:00");


!^screenshot-1.png|thumbnail!

The following error is generated when clicked on the url in the Web Console | Connections
page : 

[^screenshot-2.png]

I see that the ‘+’ sign isn’t correct encoded in the URL. 

It is : *{color:red}+{color}* 
http://testactivemq:8161/admin/connection.jsp?connectionID=%3Cmy%20unique%20id%3E|2017-08-01T09:20:18.936{color:red}*+*{color}03:00


And it should perhaps be : *{color:red}%2B {color}*
http://testactivemq:8161/admin/connection.jsp?connectionID=%3Cmy%20unique%20id%3E|2017-08-01T09:20:18.936{color:red}*%2B*{color}03:00



  was:
I’m trying to use an ISO 8601 date/time as part of the ClientID. 

For example : connection.setClientID("<my unique id>|2017-08-01T09:20:18.936+03:00");


!screenshot-1.png|thumbnail!

The following error is generated when clicked on the url in the Web Console | Connections
page : 

[^screenshot-2.png]

I see that the ‘+’ sign isn’t correct encoded in the URL. 

It is : *{color:red}+{color}* 
http://testactivemq:8161/admin/connection.jsp?connectionID=%3Cmy%20unique%20id%3E|2017-08-01T09:20:18.936{color:red}*+*{color}03:00


And it should perhaps be : *{color:red}%2B {color}*
http://testactivemq:8161/admin/connection.jsp?connectionID=%3Cmy%20unique%20id%3E|2017-08-01T09:20:18.936{color:red}*%2B*{color}03:00




> The ActiveMQ Web Console doesn’t support a plus (+) sign in the ClientID
> ------------------------------------------------------------------------
>
>                 Key: AMQ-6781
>                 URL: https://issues.apache.org/jira/browse/AMQ-6781
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: webconsole
>    Affects Versions: 5.14.1, 5.15.0
>            Reporter: Patrick Vansevenant
>            Priority: Minor
>         Attachments: screenshot-1.png, screenshot-2.png
>
>
> I’m trying to use an ISO 8601 date/time as part of the ClientID. 
> For example : connection.setClientID("<my unique id>|2017-08-01T09:20:18.936+03:00");

> !^screenshot-1.png|thumbnail!
> The following error is generated when clicked on the url in the Web Console | Connections
page : 
> [^screenshot-2.png]
> I see that the ‘+’ sign isn’t correct encoded in the URL. 
> It is : *{color:red}+{color}* 
> http://testactivemq:8161/admin/connection.jsp?connectionID=%3Cmy%20unique%20id%3E|2017-08-01T09:20:18.936{color:red}*+*{color}03:00

> And it should perhaps be : *{color:red}%2B {color}*
> http://testactivemq:8161/admin/connection.jsp?connectionID=%3Cmy%20unique%20id%3E|2017-08-01T09:20:18.936{color:red}*%2B*{color}03:00




--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message