activemq-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "clebert suconic (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (ARTEMIS-772) reusing subscription id with different topic gives unexpected behaviour
Date Mon, 08 May 2017 19:24:04 GMT

     [ https://issues.apache.org/jira/browse/ARTEMIS-772?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

clebert suconic closed ARTEMIS-772.
-----------------------------------
    Resolution: Duplicate

I don't think this is still an issue. please reopen otherwise.

> reusing subscription id with different topic gives unexpected behaviour
> -----------------------------------------------------------------------
>
>                 Key: ARTEMIS-772
>                 URL: https://issues.apache.org/jira/browse/ARTEMIS-772
>             Project: ActiveMQ Artemis
>          Issue Type: Bug
>          Components: AMQP
>            Reporter: Gordon Sim
>
> I create a durable receiver in amqp using client-id myclient, link name mysub and address
topic1. I can then receive messages sent to topic 1 as expected.
> However if I then detach (implicit or explicit) without closed=true, and the attach using
the same link name but specifying topic2 as the address, I get a response from the broker
saying attached top topic2 but will not receive any messages sent to topic2. It will receive
messages sent to topic 1.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message