activemq-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Justin Bertram (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ARTEMIS-933) Artemis cluster with ha-policy replication is not working
Date Wed, 01 Mar 2017 21:29:46 GMT

    [ https://issues.apache.org/jira/browse/ARTEMIS-933?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15891070#comment-15891070
] 

Justin Bertram commented on ARTEMIS-933:
----------------------------------------

After slighly modifying the attached configurations I tested this scenario by running all
three instances on my box with both 1.5.3 and the current master branch.  As soon as I stopped
the live broker the first slave took over and became live.  Then when I stopped the now-live-slave
the second slave became live.

There are 4 replicated HA examples shipped with Artemis.  Do any of those work for you?

> Artemis cluster with ha-policy replication is not working
> ---------------------------------------------------------
>
>                 Key: ARTEMIS-933
>                 URL: https://issues.apache.org/jira/browse/ARTEMIS-933
>             Project: ActiveMQ Artemis
>          Issue Type: Bug
>    Affects Versions: 1.3.0
>            Reporter: Gerrit Tamboer
>            Priority: Blocker
>         Attachments: master-broker.xml, slave-01-broker.xml, slave-02-broker.xml
>
>
> We are attempting to setup a 3 node cluster with a active-passive failover situation.
We see that the master node is actively accepting connections:
> {code}
> 09:52:30,167 INFO  [org.apache.activemq.artemis.core.server] AMQ221000: live Message
Broker is starting with configuration Broker Configuration (clustered=true,journalDirectory=./data/journal,bindingsDirectory=./data/bindings,largeMessagesDirectory=./data/large-messages,pagingDirectory=/opt/jamq_paging_data/data)
> 09:52:33,176 INFO  [org.apache.activemq.artemis.core.server] AMQ221020: Started Acceptor
at 0.0.0.0:61616 for protocols [CORE,MQTT,AMQP,HORNETQ,STOMP,OPENWIRE]
> {code}
> The slaves are able to connect to the master and are reporting that they are in standby
mode:
> {code}
> 08:16:57,426 INFO  [org.apache.activemq.artemis.core.server] AMQ221000: backup Message
Broker is starting with configuration Broker Configuration (clustered=true,journalDirectory=./data/journal,bindingsDirectory=./data/bindings,largeMessagesDirectory=./data/large-messages,pagingDirectory=/opt/jamq_paging_data/data)
> 08:18:38,529 INFO  [org.apache.activemq.artemis.core.server] AMQ221109: Apache ActiveMQ
Artemis Backup Server version 1.3.0 [null] started, waiting live to fail before it gets active
> {code}
> However, when I kill the master node now, it reports that the master is gone , but does
not become active itself:
> {code}
> 08:20:14,987 WARN  [org.apache.activemq.artemis.core.client] AMQ212037: Connection failure
has been detected: AMQ119015: The connection was disconnected because of server shutdown [code=DISCONNECTED]
> {code}
> When I do a kill -9 on the PID of the master java process, it does not even report that
the master has gone away.
> I also tested this in 1.5.1, with the same results.
> My expectation is that if the master dies, one of the slaves becomes active.
> Attached you will find the broker.xml of all 3 nodes.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message