activemq-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christopher L. Shannon (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (AMQ-6584) ActiveMQ does not work on karaf 4.1.0
Date Mon, 27 Feb 2017 12:43:46 GMT

     [ https://issues.apache.org/jira/browse/AMQ-6584?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Christopher L. Shannon resolved AMQ-6584.
-----------------------------------------
    Resolution: Fixed

> ActiveMQ does not work on karaf 4.1.0
> -------------------------------------
>
>                 Key: AMQ-6584
>                 URL: https://issues.apache.org/jira/browse/AMQ-6584
>             Project: ActiveMQ
>          Issue Type: Bug
>          Components: karaf
>            Reporter: Christian Schneider
>            Assignee: Christian Schneider
>             Fix For: 5.13.6, 5.15.0, 5.14.4
>
>
> feature:repo-add activemq 5.14.3
> karaf@root()> feature:install activemq                                           
                                                  10:10:38
> Error executing command: Unable to resolve root: missing requirement [root] osgi.identity;
osgi.identity=activemq; type=karaf.feature; version="[5.14.3,5.14.3]"; filter:="(&(osgi.identity=activemq)(type=karaf.feature)(version>=5.14.3)(version<=5.14.3))"
[caused by: Unable to resolve activemq/5.14.3: missing requirement [activemq/5.14.3] osgi.identity;
osgi.identity=activemq-client; type=karaf.feature; version="[5.14.3,5.14.3]" [caused by: Unable
to resolve activemq-client/5.14.3: missing requirement [activemq-client/5.14.3] osgi.identity;
osgi.identity=org.apache.activemq.activemq-osgi; type=osgi.bundle; version="[5.14.3,5.14.3]";
resolution:=mandatory [caused by: Unable to resolve org.apache.activemq.activemq-osgi/5.14.3:
missing requirement [org.apache.activemq.activemq-osgi/5.14.3] osgi.wiring.package; filter:="(osgi.wiring.package=org.aopalliance.aop)"]]]
> karaf@root()> feature:install activemq-client                                    
                                                  10:10:41
> Error executing command: Unable to resolve root: missing requirement [root] osgi.identity;
osgi.identity=activemq-client; type=karaf.feature; version="[5.14.3,5.14.3]"; filter:="(&(osgi.identity=activemq-client)(type=karaf.feature)(version>=5.14.3)(version<=5.14.3))"
[caused by: Unable to resolve activemq-client/5.14.3: missing requirement [activemq-client/5.14.3]
osgi.identity; osgi.identity=spring; type=karaf.feature; version="[3.2.0,4.0.0)"]



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message